Skip site navigation (1) Skip section navigation (2)

rpm install issues - RHE3

From: Chris Jensen <iamameatpopsicle(at)gmail(dot)com>
To: pgsql-novice(at)postgresql(dot)org
Subject: rpm install issues - RHE3
Date: 2005-03-30 18:07:23
Message-ID: 14972dbd050330100744734bf3@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-novice
i need to install PostGreSQL 8.0.1 on my RedHat Enterprise 3 server. 
i'm using the postgresql-8.01-2PGDG.x86_64.rpm package, and it's
paired server package.  i get a lot of dependency failures on an rpm
-ivh command, but when i check to see if i have the required
dependencies everything seems to be there.  can someone tell me if
there's a better way i can do this?  i am hesitant to compile from
source because of all of the rpm problems.  i'm still relatively new
to Linux and very new to PostGreSQL

thanks in advance!
Chris


here are my dependency problems:

rpm -ivh *
warning: postgresql-8.0.1-2PGDG.x86_64.rpm: V3 DSA signature: NOKEY,
key ID ddcd9f9a
error: Failed dependencies:
        libc.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6(GLIBC_2.3)(64bit) is needed by postgresql-8.0.1-2PGDG
        libcom_err.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypt.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libcrypto.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libdl.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libm.so.6()(64bit) is needed by postgresql-8.0.1-2PGDG
        libncurses.so.5()(64bit) is needed by postgresql-8.0.1-2PGDG
        libnsl.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpam.so.0()(64bit) is needed by postgresql-8.0.1-2PGDG
        libpq.so.3()(64bit) is needed by postgresql-8.0.1-2PGDG
        libreadline.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libresolv.so.2()(64bit) is needed by postgresql-8.0.1-2PGDG
        libssl.so.4()(64bit) is needed by postgresql-8.0.1-2PGDG
        libz.so.1()(64bit) is needed by postgresql-8.0.1-2PGDG
        libc.so.6()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libc.so.6(GLIBC_2.2.5)(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libc.so.6(GLIBC_2.3)(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libcom_err.so.2()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libcrypt.so.1()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by
postgresql-server-8.0.1-2PGDG
        libcrypto.so.4()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libdl.so.2()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libdl.so.2(GLIBC_2.2.5)(64bit) is needed by
postgresql-server-8.0.1-2PGDG
        libkrb5.so.3()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libm.so.6()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libm.so.6(GLIBC_2.2.5)(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libncurses.so.5()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libnsl.so.1()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libpam.so.0()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libpq.so.3()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libreadline.so.4()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libresolv.so.2()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libssl.so.4()(64bit) is needed by postgresql-server-8.0.1-2PGDG
        libz.so.1()(64bit) is needed by postgresql-server-8.0.1-2PGDG

Responses

pgsql-novice by date

Next:From: Celia McInnisDate: 2005-03-30 18:29:58
Subject: how to ignore accents?
Previous:From: Michael FuhrDate: 2005-03-30 17:14:24
Subject: Re: Quote Question

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group