Skip site navigation (1) Skip section navigation (2)

Re: Upgrading our minimum required flex version for 8.5

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Andrew Dunstan <andrew(at)dunslane(dot)net>
Cc: Alvaro Herrera <alvherre(at)commandprompt(dot)com>, Kevin Grittner <Kevin(dot)Grittner(at)wicourts(dot)gov>, pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: Upgrading our minimum required flex version for 8.5
Date: 2009-07-02 17:13:50
Message-ID: 1433.1246554830@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackers
I wrote:
> Yes.  What I was thinking of doing was committing a configure change to
> reject flex < 2.5.31, and waiting to see how much of the buildfarm goes
> red.

Actually, most of the buildfarm members show which flex version they are
running in the configure output.  A quick look shows that of the 45
members that have reported on HEAD in the past 2 days, 22 are running
2.5.4, which is a lot higher than I was expecting.  Most of these are
the Solaris boxen, which I imagine can be updated fairly painlessly
since there are some of them that are already running something newer.
However I'm a bit worried about the situation for Windows --- does
anyone know whether a newer flex is readily available for Windows?

In any case it seems like it'd be prudent to prod the buildfarm owners
to update their flex *before* we pull the trigger...

			regards, tom lane

In response to

Responses

pgsql-hackers by date

Next:From: Tom LaneDate: 2009-07-02 17:16:46
Subject: Re: Upgrading our minimum required flex version for 8.5
Previous:From: Kevin GrittnerDate: 2009-07-02 17:10:49
Subject: Re: Upgrading our minimum required flex version for 8.5

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group