Skip site navigation (1) Skip section navigation (2)

During InitDB: could not access file "$libdir/ascii_and_mic" (probably because there are no .so files?)

From: Vitaly Belman <vitalib(at)012(dot)net(dot)il>
To: pgsql-hackers-win32(at)postgresql(dot)org
Subject: During InitDB: could not access file "$libdir/ascii_and_mic" (probably because there are no .so files?)
Date: 2004-03-26 12:16:59
Message-ID: (view raw or whole thread)
Lists: pgsql-hackers-win32
Hello pgsql-hackers-win32,

  I downloaded today the postgresql snapshot and tried to make it

  I followed the compile direction presented here:

  From MSYS I did:
  * configure --without-zlib
  * make
  Then it compiles successfully (or so I think) - I saw no specific
  fatal errors or anything of the king, though there were a few
  warnings now and then

  Afterward I copied the "libpq.dll" to the SYSTEM32 dir and tried to

  initdb -D data (from CMD.exe)

  At first it complained about files not being in "local\pgsql\share"
  and "local\pgsql\bin". So I copied the needed files from the src
  folder. Then I tried again.

  The output was:

> creating directory Data ... ok
> creating directory Data/global ... ok
> creating directory Data/pg_xlog ... ok
> creating directory Data/pg_clog ... ok
> creating directory Data/base ... ok
> creating directory Data/base/1 ... ok
> selecting default max_connections ... 100
> selecting default shared_buffers ... 1000
> creating configuration files ... ok
> creating template1 database in Data/base/1 ... ok
> initializing pg_shadow ... ok
> enabling unlimited row size for system tables ... ok
> initializing pg_depend ... ok
> creating system views ... ok
> loading pg_description ... ok
> creating conversions ... ERROR:  could not access file "$libdir/ascii_and_mic":
> No such file or directory
> initdb: child process was terminated by signal 1
> initdb: failed
> initdb: removing data directory "Data"

  From what I read, the $libdir is the following directory: local\pgsql\lib
  I create this structure and put the whole "ascii_and_mic" directory
  inside (as I was unsure what file it needs). I read somewhere that
  it needs the "" file but no files with this
  extension were created during the compilation so I am baffled about
  where do I take these .so files from and why weren't they created in
  the first place.

  Also, I am a bit confused about the directory issue... Did I have to
  copy files manually to a directory structure that I created?
  Shouldn't have the makefile move all the files to their appropriate

  P.S If it isn't obvious, I am a linux newbie - I compiled/ran stuff
  on cygwin a few times but I never had any real Linux experience, so
  please keep this in mind if you post an answer. "Bootstrap" and
  "Postadmin" as words don't tell me too much.

 Vitaly Belman
 ICQ: 1912453
 AIM: VitalyB1984
 MSN: tmdagent(at)hotmail(dot)com
 Yahoo!: VitalyBe

pgsql-hackers-win32 by date

Next:From: Claudio NatoliDate: 2004-03-26 12:36:10
Subject: Re: During InitDB: could not access file "$
Previous:From: Claudio NatoliDate: 2004-03-24 23:10:01
Subject: Re: pg_ctl

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group