Skip site navigation (1) Skip section navigation (2)

Re: [DOCS] Avoiding upgrade backlash

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: josh(at)agliodbs(dot)com
Cc: pgsql-advocacy(at)postgresql(dot)org, pgsql-docs(at)postgresql(dot)org
Subject: Re: [DOCS] Avoiding upgrade backlash
Date: 2007-11-12 23:04:12
Message-ID: 13606.1194908652@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-advocacypgsql-docs
Josh Berkus <josh(at)agliodbs(dot)com> writes:
> While we are right to choke down abuse of implicit casting, it might be a 
> good idea to give users stronger warnings and instructions.  

> I'm thinking that we need to warn everyone about:
> 1) They need to use 8.3's pg_dump, not the old version, to upgrade (this is 
> always true but now doing it wrong will break a lot more users).

Uh, what makes you think that will make any difference?

> 3) If Robert gets his type-cast backport package together, the location of 
> that.

The very *last* thing I want to see is encouragement of people trying to
undo that change.

			regards, tom lane

In response to

pgsql-docs by date

Next:From: Andrew SullivanDate: 2007-11-13 00:13:23
Subject: Re: Avoiding upgrade backlash
Previous:From: Josh BerkusDate: 2007-11-12 22:42:30
Subject: Avoiding upgrade backlash

pgsql-advocacy by date

Next:From: Josh BerkusDate: 2007-11-12 23:38:18
Subject: Re: Argentina and advocacy (re: regional contacts)
Previous:From: Josh BerkusDate: 2007-11-12 22:42:30
Subject: Avoiding upgrade backlash

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group