Skip site navigation (1) Skip section navigation (2)

Re: pg_dump 7.3rc1 with 7.2 server.

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Robert Treat <xzilla(at)users(dot)sourceforge(dot)net>
Cc: mallah(at)trade-india(dot)com, pgsql-admin(at)postgresql(dot)org
Subject: Re: pg_dump 7.3rc1 with 7.2 server.
Date: 2002-11-27 03:24:44
Message-ID: 13496.1038367484@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-admin
Robert Treat <xzilla(at)users(dot)sourceforge(dot)net> writes:
> I've not tested it, so I can say 100% for sure, but if I had to guess
> I'd say that those dumps wont work if you try to restore to 7.2.1 so you
> need to switch back to the proper version asap.

Robert's right: the output of 7.3 pg_dump will not load into older
servers.  In general, pg_dump can read from older servers (back to
7.0) but its output will only load into same- or newer-version servers.

Of course, if you *did* have a crash you could install 7.3rc2 and reload
into that ...

			regards, tom lane

In response to

Responses

pgsql-admin by date

Next:From: Tom LaneDate: 2002-11-27 04:41:28
Subject: Re: ALLOW_ABSOLUTE_DBPATHS
Previous:From: Robert TreatDate: 2002-11-26 19:49:49
Subject: Re: pg_dump 7.3rc1 with 7.2 server.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group