Skip site navigation (1) Skip section navigation (2)

Re: BUG #6729: Install of postgresql-devel for x86_84 and i686 fails

From: Devrim GÜNDÜZ <devrim(at)gunduz(dot)org>
To: ysharma(at)cymer(dot)com
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #6729: Install of postgresql-devel for x86_84 and i686 fails
Date: 2012-07-12 20:19:18
Message-ID: 1342124358.18166.28.camel@lenovo01-laptop03.gunduz.org (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi,

It is not a bug, but it might be a missing feature (and I'm not sure how
to fix it :-) )

Regards,

On Wed, 2012-07-11 at 23:16 +0000, ysharma(at)cymer(dot)com wrote:
> The following bug has been logged on the website:
> 
> Bug reference:      6729
> Logged by:          Yogesh Sharma
> Email address:      ysharma(at)cymer(dot)com
> PostgreSQL version: 9.1.4
> Operating system:   CentOS 6.3
> Description:        
> 
> For compilation of 64bit as well 32bit program I am trying to install both
> versions. Here is error:
> 
> ================================================================================================================================================================================
>  Package                                Arch                       Version  
>                             Repository                                      
>                  Size
> ================================================================================================================================================================================
> Installing:
>  postgresql91-devel                     i686                      
> 9.1.4-1PGDG.rhel6                    
> /postgresql91-devel-9.1.4-1PGDG.rhel6.i686                       5.4 M
>  postgresql91-devel                     x86_64                    
> 9.1.4-1PGDG.rhel6                    
> /postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64                     6.2 M
> 
> Transaction Summary
> ================================================================================================================================================================================
> Install       2 Package(s)
> 
> Total size: 12 M
> Installed size: 12 M
> Is this ok [y/N]: y
> Downloading Packages:
> Running rpm_check_debug
> Running Transaction Test
> 
> 
> Transaction Check Error:
>   file /usr/pgsql-9.1/lib/libecpg.a conflicts between attempted installs of
> postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
>   file /usr/pgsql-9.1/lib/libecpg_compat.a conflicts between attempted
> installs of postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
>   file /usr/pgsql-9.1/lib/libpgport.a conflicts between attempted installs
> of postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
>   file /usr/pgsql-9.1/lib/libpgtypes.a conflicts between attempted installs
> of postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
>   file /usr/pgsql-9.1/lib/libpq.a conflicts between attempted installs of
> postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
>   file /usr/pgsql-9.1/lib/pgxs/src/Makefile.global conflicts between
> attempted installs of postgresql91-devel-9.1.4-1PGDG.rhel6.x86_64 and
> postgresql91-devel-9.1.4-1PGDG.rhel6.i686
> 
> Error Summary
> -------------
> 
> 
> 


-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Community: devrim~PostgreSQL.org, devrim.gunduz~linux.org.tr
http://www.gunduz.org  Twitter: http://twitter.com/devrimgunduz

In response to

Responses

pgsql-bugs by date

Next:From: Tom LaneDate: 2012-07-12 20:36:52
Subject: Re: BUG #6729: Install of postgresql-devel for x86_84 and i686 fails
Previous:From: Tom LaneDate: 2012-07-12 17:25:22
Subject: Re: BUG #6732: Build issue when using gettext on FreeBSD 9

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group