Skip site navigation (1) Skip section navigation (2)

Re: postgres + php + versión

From: Gilberto Castillo Martínez <gilberto(dot)castillo(at)etecsa(dot)cu>
To: Guillermo Villanueva <guillermovil(at)gmail(dot)com>
Cc: pgsql-es-ayuda <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: Re: postgres + php + versión
Date: 2012-06-14 13:18:37
Message-ID: 1339679917.4541.4.camel@gilbertoc.mtcorp.etecsa.cu (view raw or flat)
Thread:
Lists: pgsql-es-ayuda

El jue, 14-06-2012 a las 09:42 -0300, Guillermo Villanueva escribió:
> Buenos días amigos, veamos si pueden darme una manito.
> Finalmente contraté un VPS de dattatec para levantar una aplicación de
> un cliente y me di con varios inconvenientes que se los comento.
> El sistema operativo que brindan es un centos 5 y yo venía
> acostumbrado al ubuntu server. Me está costando mucho acostumbrarme.
> El apache está configurado para el uso de múltiples dominios. No saben
> lo que me está costando encontrar archivos de configuración!!
> Había un postgres 8.1 instalado, pude instalar la versión 9.1.4 y está
> corriendo sin problemas.
> 
> El tema es que si ejecuto un phpinfo() en la parte de postgres
> muestra:
> pdo_pgsql
> PDO Driver for PostgreSQL enabled
> PostgreSQL(libpq) Version 8.1.23
> Module version 1.0.2
> Revision $Id: pdo_pgsql.c 321634 2012-01-01 13:15:04Z felipe $
> 
> pgsql
> PostgreSQL Support enabled
> PostgreSQL(libpq) Version 8.1.23
> Multibyte character support enabled
> SSL support enabled
> Active Persistent Links 0
> Active Links 0
>  
> pgsql.allow_persistent On On
> pgsql.auto_reset_persistent Off Off
> pgsql.ignore_notice Off Off
> pgsql.log_noticeOff Off
> pgsql.max_links Unlimited Unlimited
> pgsql.max_persistent Unlimited Unlimited
> 
> No debería mostrarme PostgreSQL(libpq) Version 9xx?. Funcionaban bien
> la mayoría de los accesos desde php a postgres hasta que probé la
> parte de bytea, hay un módulo que muestra una foto que tengo en un
> campo bytea y no está funcionando, no muestra nada, pero cuando corro
> exactamente lo mismo en mi server local , funciona perfectamente.
> 
> Otro problema que tengo con respecto al php y postgres es que no está
> registrando los errores de acceso a la base o no los estoy encontrando
> donde debe ser. Si tienen un tiempito les pido entonces:
> 1) Cómo hacer que php utilice las librerías correctas? (o son
> correctas las que está usando para un motor 9.1?)
> 2) Qué puede estar pasando que no muestra la foto? (adjunto el código
> php al final del mensaje)
> 3) Qué puede estar pasando que no hay log de errores de php al no
> poder acceder a la base? (ahora ya puedo , pero cuando lo estaba
> intentando, en ningún lado había un log de php y/o apache que muestre
> el problema)
> 

Llevo años trabajando con Centos 5 y PostgreSQL, sin problema alguno,
según entiendo debe instalar los paquetes adecuados de Apache o quizás
actualizar Apeche, para las imagenes hay varios módulos que debes
instalar .... ahora mismo no recuerdo y mi servidores están bien lejos
de donde estoy ... creo comienzan con imagen---- y otro gdf o algo así.



-- 
Saludos,
Gilberto Castillo
ETECSA, La Habana.Cuba.

In response to

pgsql-es-ayuda by date

Next:From: Marcos OrtizDate: 2012-06-14 14:05:16
Subject: Re: postgres + php + versión
Previous:From: Guillermo VillanuevaDate: 2012-06-14 12:42:53
Subject: postgres + php + versión

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group