Skip site navigation (1) Skip section navigation (2)

Re: 15.1 Dev + wxwidgets 2.9.3 - open query builder error

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Colin Beckingham <colbec(at)start(dot)ca>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: 15.1 Dev + wxwidgets 2.9.3 - open query builder error
Date: 2012-03-05 14:06:02
Message-ID: 1330956362.3210.6.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgadmin-support
On Sat, 2012-03-03 at 11:13 -0500, Colin Beckingham wrote:
> In 15.1 dev + wxw 2.9.3
> 
> 1. open pgadmin3 (splash screen does not appear, straight to main dialog)
> 2. click on icon for query builder, error box pops up offering backtrace 
> (posted below)
> 3. click stop in error dialog, Query Builder opens normally and old 
> queries are available and work fine.
> 
> =====================
> 
> ASSERT INFO:
> ./src/gtk/textctrl.cpp(828): assert "IsSingleLine()" failed in 
> GetEditable(): shouldn't be called for multiline
> 

Finally found the reason why. I pushed a patch from Akshay Joshi,
slightly modified by me.

Thanks for the report.


-- 
Guillaume
http://blog.guillaume.lelarge.info
http://www.dalibo.com


In response to

pgadmin-support by date

Next:From: Guillaume LelargeDate: 2012-03-05 14:06:46
Subject: Re: 1.15 dev + wxWidgets 2.9.3, properties and index
Previous:From: Guillaume LelargeDate: 2012-03-05 12:30:18
Subject: Re: Fwd: [pgadmin-support] 1.15 dev + wxWidgets 2.9.3, properties and index

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group