Skip site navigation (1) Skip section navigation (2)

Re: BUG #6341: Packaging - virtual provides "postgres" without version

From: Devrim GÜNDÜZ <devrim(at)gunduz(dot)org>
To: nelson-m-marques(at)ext(dot)ptinovacao(dot)pt
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #6341: Packaging - virtual provides "postgres" without version
Date: 2011-12-26 14:51:21
Message-ID: 1324911081.2049.7.camel@lenovo01-laptop03.gunduz.org (view raw or flat)
Thread:
Lists: pgsql-bugs
On Thu, 2011-12-15 at 16:27 +0000, nelson-m-marques(at)ext(dot)ptinovacao(dot)pt
wrote:
> 
> Is there a special reason for having a virtual provides without
> versioning?

PGDG RPMs in RHEL 6 can be installed in parallel, i.e., you can have 8.4
+ on the same machine. OTOH, os supplied RPMs does not have any version
number, and there are lots of packages that need postgresql-libs or
postgresql, etc. We "Provide" version-less packages to satisfy os
dependencies.

Regards,
-- 
Devrim GÜNDÜZ
Principal Systems Engineer @ EnterpriseDB: http://www.enterprisedb.com
PostgreSQL Danışmanı/Consultant, Red Hat Certified Engineer
Community: devrim~PostgreSQL.org, devrim.gunduz~linux.org.tr
http://www.gunduz.org  Twitter: http://twitter.com/devrimgunduz

In response to

pgsql-bugs by date

Next:From: wcting163Date: 2011-12-27 10:11:06
Subject: BUG #6360: with hold cursor,cause function executed twice and wrong results
Previous:From: Devrim GÜNDÜZDate: 2011-12-26 14:41:44
Subject: Re: BUG #6341: Packaging - virtual provides "postgres" without version

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group