Skip site navigation (1) Skip section navigation (2)

configure doesn't detect SSL support in libpq

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: configure doesn't detect SSL support in libpq
Date: 2011-12-12 21:18:40
Message-ID: 1323724720.4359.46.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgadmin-hackers
Hi,

It seems our configure script doesn't detect SSL support in libpq. It
detects the SSL library though.

The following patch fixes it, but I'm not sure of it as I'm in no way an
expert in those things;

diff --git a/acinclude.m4 b/acinclude.m4
index 4030966..0640a68 100644
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -538,7 +538,7 @@ AC_DEFUN([SETUP_POSTGRESQL],
                                        PG_SSL="no"
                                fi
                        else
-                               AC_CHECK_LIB(pq, SSL_connect,
[PG_SSL=yes], [PG_SSL=no])
+                               AC_CHECK_LIB(pq, SSL_connect,
[PG_SSL=yes], [PG_SSL=no], "-lssl")
                        fi
                fi
                else

Any comments would be appreciated :)


-- 
Guillaume
  http://blog.guillaume.lelarge.info
  http://www.dalibo.com


Responses

pgadmin-hackers by date

Next:From: Guillaume LelargeDate: 2011-12-12 22:34:22
Subject: pgAdmin III commit: Add support for the new sslcompression connectiono
Previous:From: pgAdmin TracDate: 2011-12-12 20:26:27
Subject: Re: [pgAdmin III] #341: New connection option: sslcompression

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group