Skip site navigation (1) Skip section navigation (2)

Re: [pgsql-cluster-hackers] Fwd: Invalid version while creating PostgreSQL 9.1 cluster

From: Hannu Krosing <hannu(at)2ndQuadrant(dot)com>
To: Виктор Столбин <viktor(dot)stolbin(at)gmail(dot)com>
Cc: pgsql-cluster-hackers(at)postgresql(dot)org, pgsql-pkg-debian(at)postgresql(dot)org, pgsql-admin(at)postgresql(dot)org
Subject: Re: [pgsql-cluster-hackers] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Date: 2011-09-23 18:26:41
Message-ID: 1316802401.2907.19.camel@hvost (view raw or flat)
Thread:
Lists: pgsql-adminpgsql-cluster-hackerspgsql-pkg-debian
On Fri, 2011-09-23 at 16:38 +0400, Виктор Столбин wrote:
> Hello!

Firts, this list is not for pg_*cluster, but rather clustering, high
availability and replication solutions 

> I'm trying create a cluster with existing data directory on Debian 
> 2.6.26-2-686-bigmem. I use PostgreSQL 8.3 installed from apt-get and 
> PostgreSQL 9.1 installed from 
> [OpenSCG](http://www.openscg.org/se/oscg_download.jsp?file=packages/postgres-9.1.0-1.i386.openscg.deb&user=) 
> I want to create cluster with existing data directory and add it to 
> postgresql-commons using command:
> 
> pg_createcluster -d /opt/postgres/9.1/data/ -e UTF8 --locale ru_Ru -p 
> 6432 9.1 MAIN_RU
> 
> The result is:
> 
> Error: invalid version: 9.1

Looks like your version of postgresql-common does not yet know about 9.1

Try using packages from 

https://launchpad.net/~pitti/+archive/postgresql

> I found this question 
> http://serverfault.com/questions/288612/cant-create-clusters-in-postgresql-9-0 
> but it seems in my case the problem is in postresql-commons package or 
> in PostgreSQL 9.1 package that is installed.
> 
> aptitude show postgresql-common
> Package: postgresql-common
> New: yes
> State: installed
> Automatically installed: yes
> Version: 94lenny1
> Priority: optional
> Section: misc
> Maintainer: Martin Pitt <mpitt(at)debian(dot)org>
> Uncompressed Size: 496k
> Depends: postgresql-client-common (>= 94lenny1), procps, adduser,
> debconf (>=
> 0.5.00) | debconf-2.0, lsb-base (>= 3.0-3)
> Recommends: ssl-cert (>= 1.0.11)
> Conflicts: postgresql (< 7.5), postgresql-7.4 (< 1:7.4.8-10),
> postgresql-8.0 (<
> 8.0.3-7), postgresql-client (< 7.5)
> Replaces: postgresql (< 7.5), postgresql-client (< 7.5)
> 
> 
> Update.
> 
> I check this on Ubuntu 2.6.32-24-generic #39 with same deb packages, the 
> problem is the same. I think it's in postgresql-commons facilities 
> packaged in OpenSCG deb. PostgreSQL 9.1 is released 2011-09-11.
> 
> Any help would be appreciated!
> 
> Best Regurds,
> Viktor Stolbin
> Grffolabs LTD
> 
> 

-- 
-------
Hannu Krosing
PostgreSQL Unlimited Scalability and Performance Consultant
2ndQuadrant Nordic
PG Admin Book: http://www.2ndQuadrant.com/books/


In response to

pgsql-pkg-debian by date

Next:From: Christoph BergDate: 2011-09-23 21:00:09
Subject: Re: [pgsql-pkg-debian] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Previous:From: Виктор СтолбинDate: 2011-09-23 12:38:00
Subject: Fwd: Invalid version while creating PostgreSQL 9.1 cluster

pgsql-cluster-hackers by date

Next:From: Christoph BergDate: 2011-09-23 21:00:09
Subject: Re: [pgsql-pkg-debian] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Previous:From: Виктор СтолбинDate: 2011-09-23 12:38:00
Subject: Fwd: Invalid version while creating PostgreSQL 9.1 cluster

pgsql-admin by date

Next:From: Burgholzer, Robert (DEQ)Date: 2011-09-23 19:02:49
Subject: diagnosing a db crash - server exit code 2
Previous:From: Виктор СтолбинDate: 2011-09-23 12:38:00
Subject: Fwd: Invalid version while creating PostgreSQL 9.1 cluster

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group