Skip site navigation (1) Skip section navigation (2)

Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: Giuseppe Sacco <giuseppe(at)eppesuigoccas(dot)homedns(dot)org>, pgadmin-support(at)postgresql(dot)org
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati
Date: 2011-08-24 10:15:44
Message-ID: 1314180944.2193.16.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgadmin-support
On Wed, 2011-08-24 at 11:00 +0100, Dave Page wrote:
> On Wed, Aug 24, 2011 at 10:40 AM, Giuseppe Sacco
> <giuseppe(at)eppesuigoccas(dot)homedns(dot)org> wrote:
> > Il giorno mer, 24/08/2011 alle 10.04 +0100, Dave Page ha scritto:
> >> On Wed, Aug 24, 2011 at 9:54 AM, Giuseppe Sacco
> > [...]
> >> > Config log show something about ssl: it seems libpq is detected but not
> >> > usable since configure cannot compile with it. libpq require ssl, and I
> >> > have openssl 1.0.0d instead of older version. From error messages it
> >> > seems libpq cannot work with this version of openssl. Is this true at
> >> > all?
> >>
> >> Doubtful, unless the Debian package is horribly broken. What's the error?
> >
> > $ ls -l /usr/lib/libssl*
> > -rw-r--r-- 1 root root 431786 13 giu 14.03 /usr/lib/libssl.a
> > lrwxrwxrwx 1 root root     15 13 giu 14.03 /usr/lib/libssl.so -> libssl.so.1.0.0
> > -rw-r--r-- 1 root root 302608  6 apr 20.01 /usr/lib/libssl.so.0.9.8
> > -rw-r--r-- 1 root root 312588 13 giu 14.03 /usr/lib/libssl.so.1.0.0

Same as mine.

> > $ dpkg -S /usr/lib/libssl.so.1.0.0
> > libssl1.0.0: /usr/lib/libssl.so.1.0.0
> > $ dpkg -l libssl-dev libssl0.9.8 libssl1.0.0 openssl
> > Desired=Unknown/Install/Remove/Purge/Hold
> > | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
> > |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
> > ||/ Nome                       Versione                   Descrizione
> > +++-==========================-==========================-====================================================================
> > ii  libssl-dev                 1.0.0d-3                   SSL development libraries, header files and documentation
> > ii  libssl0.9.8                0.9.8o-7                   SSL shared libraries
> > ii  libssl1.0.0                1.0.0d-3                   SSL shared libraries
> > ii  openssl                    1.0.0d-3                   Secure Socket Layer (SSL) binary and related cryptographic tools
> >

Same as mine.

> > So I do have both libssl installed. The default one is 1.0.0d. include files are from 1.0.0d.
> >
> > This is the part of ssl check in config.log. Later on, when checking for
> > lipq, the list of errors is almost the same. I think (at least a few of)
> > these errors could be solved linking with libcrypto.so as well.
> >
> > configure:5403: checking for SSL_library_init in -lssl
> > configure:5428: gcc -o conftest -g -O2   conftest.c -lssl   >&5
> > /usr/lib/libssl.so: undefined reference to `BIO_pop(at)OPENSSL_1(dot)0(dot)0'
> > /usr/lib/libssl.so: undefined reference to `EVP_CipherInit_ex(at)OPENSSL_1(dot)0(dot)0'
> 
> <snip>
> 
> What version of SSL is your libpq compiled against? You can use 'ldd'
> to find out. On squeeze, PG 8.4 appears to use 0.9.8.
> 

FYI, mine is:
root(at)debian:~# ldd /usr/lib/libpq.so.5.4 | grep ssl
	libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007f511f911000)

And ldd on libssl gives me this:
root(at)debian:~# ldd /usr/lib/libssl.so.1.0.0
	linux-vdso.so.1 =>  (0x00007fffcf3ff000)
	libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007ffccd12a000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ffcccf26000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007ffcccd0e000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ffccc98a000)
	/lib64/ld-linux-x86-64.so.2 (0x00007ffccd756000)


-- 
Guillaume
  http://blog.guillaume.lelarge.info
  http://www.dalibo.com


In response to

Responses

pgadmin-support by date

Next:From: Giuseppe SaccoDate: 2011-08-24 10:18:09
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati
Previous:From: Guillaume LelargeDate: 2011-08-24 10:08:55
Subject: Re: compiling on debian does not find a valid PostgreSQL 8.4+ installati

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group