On Thu, 2010-06-10 at 10:18 +0300, Heikki Linnakangas wrote:
> On 09/06/10 10:21, Simon Riggs wrote:
> > On Tue, 2010-06-08 at 18:30 -0400, Andrew Dunstan wrote:
> >> I prefer archive_cleanup_command. We should name things after their
> >> principal function, not an implementation detail, IMNSHO.
> >> More importantly, we should include an example in the docs. I created
> >> one the other day when this was actually bothering me a bit (see
> >> <http://people.planetpostgresql.org/andrew/index.php?/archives/85-Keeping-a-hot-standby-log-archive-clean.html>).
> >> That seemed to work ok, but maybe it's too long, and maybe people would
> >> prefer a shell script to perl.
> > I submitted a patch to make the command "pg_standby -a %r"
> > That's a more portable solution, ISTM.
> > I'll commit that and fix the docs.
> Huh, wait. There's no -a option in pg_standby, so I presume you're
> planning to add that too. I don't like confusing pg_standby into this,
> the docs are currently quite clear that if you want to use the built-in
> standby mode, you can't use pg_standby, and this would muddy the waters.
It won't kill us to change that sentence. "pg_standby is only used now
within the cleanup command" etc
pg_standby already contains the exact logic we need here. Having two
sets of code for the same thing isn't how we do things.
> Maybe we could add a new pg_cleanuparchive binary, but we'll need some
Which will go nowhere, as we both already know.
Simon Riggs www.2ndQuadrant.com
In response to
pgsql-hackers by date
|Next:||From: Fujii Masao||Date: 2010-06-10 07:43:01|
|Subject: Re: InvalidXLogRecPtr in docs|
|Previous:||From: Fujii Masao||Date: 2010-06-10 07:25:07|
|Subject: variable TriggerFile can be declared as static|