Skip site navigation (1) Skip section navigation (2)

Re: pgsql: Small stylistic improvement in recent FORCE QUOTE * code - use a

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Andrew Dunstan <andrew(at)dunslane(dot)net>
Cc: pgsql-committers(at)postgresql(dot)org
Subject: Re: pgsql: Small stylistic improvement in recent FORCE QUOTE * code - use a
Date: 2009-07-25 17:07:51
Message-ID: 12355.1248541671@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-committers
adunstan(at)postgresql(dot)org (Andrew Dunstan) writes:
> Log Message:
> -----------
> Small stylistic improvement in recent FORCE QUOTE * code - use a bool instead of a magic value.

This actually broke things a bit.  I agree that the original coding with
a phony list header was horridly ugly, but it did have one redeeming
value: namely that the various existing tests for force_quote not empty
still worked as-is.  With the separate bool you need to extend all those
checks.  On balance it still seems cleaner that way, though, so I made
the necessary fixes.

			regards, tom lane

In response to

Responses

pgsql-committers by date

Next:From: Andrew DunstanDate: 2009-07-25 17:21:04
Subject: Re: pgsql: Small stylistic improvement in recent FORCE QUOTE * code - use a
Previous:From: Tom LaneDate: 2009-07-25 17:04:20
Subject: pgsql: Code review for FORCE QUOTE * patch: fix error checking to

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group