Skip site navigation (1) Skip section navigation (2)

Re: pgAdmin hang on connection drop/reconnect

From: Maciek Sakrejda <msakrejda(at)truviso(dot)com>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: pgAdmin hang on connection drop/reconnect
Date: 2008-03-31 20:59:47
Message-ID: 1206997187.15809.24.camel@maciek-desktop.sm.truviso.com (view raw or flat)
Thread:
Lists: pgadmin-support
I was able to reproduce this on 1.8.2, building from source (and I get
the hang this time, not the segfault). A small dialog box comes up to
tell me something (possibly that it's about to segfault), but it's not
drawn correctly (presumably because the refresh drawing routines don't
get called correctly by that point), so I'm not sure what it says. Then
pgAdmin stays like this until I try to close that dialog, at which point
I get the "Not responding/Wait/Force Quit" dialog box from Gnome.

I noticed that I get the following on the command line where I start
pgadmin:

Xlib: unexpected async reply (sequence 0xf810)!
-- 
Maciek Sakrejda
Truviso, Inc.
http://www.truviso.com

-----Original Message-----
From: Maciek Sakrejda <msakrejda(at)truviso(dot)com>
To: Dave Page <dpage(at)pgadmin(dot)org>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: [pgadmin-support] pgAdmin hang on connection drop/reconnect
Date: Thu, 27 Mar 2008 09:53:29 -0700

1.8.1 on Ubuntu 7.10 (x86), compiled from source. I did a fresh compile
(with default configure options) just to make sure I had a clean build,
and this time, instead of hanging, I got a segfault:

(pgadmin3:13290): GLib-GObject-WARNING **: g_type_instance_get_private()
requires a prior call to g_type_class_add_private()
Segmentation fault (core dumped)

I will try 1.8.2 and see if that still happens.
-- 
Maciek Sakrejda
Truviso, Inc.
http://www.truviso.com

-----Original Message-----
From: Dave Page <dpage(at)pgadmin(dot)org>
To: Maciek Sakrejda <msakrejda(at)truviso(dot)com>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: [pgadmin-support] pgAdmin hang on connection drop/reconnect
Date: Thu, 27 Mar 2008 16:07:58 +0000

On Mon, Mar 24, 2008 at 5:04 PM, Maciek Sakrejda <msakrejda(at)truviso(dot)com> wrote:
> pgAdmin hangs when connection drops while trying to execute a query
>
>  Steps to reproduce:
>
>  1. Open SQL query pane
>  2. Type "SELECT pg_sleep(10);"
>  3. Shut down postgres in less than ten seconds (the query in pgAdmin
>  will error out)
>  4. Start postgres
>  5. Re-run the query
>
>  Result: pgAdmin will hang.

When I try this, pgAdmin complains that there is no connection and
drops you back at the query window where you can choose a new
connection from the drop down menu.

What platform/version etc. were you using?







In response to

Responses

pgadmin-support by date

Next:From: Erwin BrandstetterDate: 2008-04-01 00:00:24
Subject: Re: Grant RULE removed in pg 8.2
Previous:From: Guy RouillierDate: 2008-03-31 18:19:22
Subject: Re: Database structure and relation viewer/editor

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group