Skip site navigation (1) Skip section navigation (2)

Re: installation of postgres 8.3 on CentOs 5.1

From: Devrim GÜNDÜZ <devrim(at)CommandPrompt(dot)com>
To: Nicholas Hemley <nic(dot)hemley(at)sidonis(dot)com>
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: installation of postgres 8.3 on CentOs 5.1
Date: 2008-02-15 19:17:54
Message-ID: 1203103074.24118.289.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgsql-novice
Hi,

On Fri, 2008-02-15 at 12:07 +0000, Nicholas Hemley wrote:
> 
> Basically, the currently installed postgresql-libs package cannot be
> removed since there is a dependency on it from the apr-util package
>  
> Therefore, i am unable to remove the older 8.1 package in order to
> install the 8.3 RPMs

rpm -ivh compat-postgresql-libs... --replacefiles

This will replace the files. Then try removing postgresql-libs. Now you
should be able to remove it, since libpq that apr-util is looking for is
already satisfied.

There is an excellent guide about this issue:

http://www.westnet.com/~gsmith/gregsmith/content/postgresql/pgrpm.htm

The package repository at http://yum.pgsqlrpms.org will solve these
problems after you fix the compat rpm issue.

Regards,
-- 
Devrim GÜNDÜZ , RHCE
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, ODBCng - http://www.commandprompt.com/

In response to

pgsql-novice by date

Next:From: Rai DeveloperDate: 2008-02-16 08:21:03
Subject: SQL LEFT JOIN and WHERE
Previous:From: JoshDate: 2008-02-15 14:58:35
Subject: Re: installation of postgres 8.3 on CentOs 5.1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group