Skip site navigation (1) Skip section navigation (2)

Re: postgresql 8.1.10-1PGDG (32 bit) installaion on RHEL 4

From: Devrim GÜNDÜZ <devrim(at)CommandPrompt(dot)com>
To: gokul(at)appshub(dot)com
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: postgresql 8.1.10-1PGDG (32 bit) installaion on RHEL 4
Date: 2007-11-13 00:44:02
Message-ID: 1194914642.6310.46.camel@localhost.localdomain (view raw or flat)
Thread:
Lists: pgsql-novice
Hi,

On Mon, 2007-11-12 at 17:20 -0500, gokul(at)appshub(dot)com wrote:

>   I'm trying to install postgresql 8.1.10-1PGDG (32 bit) on Red Hat
>   Enterprise Linux  v4.. I downloaded the rpms and tried to install it
>   when the 'pl' package alone is failing for the below dependencies.
> 
>   error: Failed dependencies:
>           libperl.so is needed by postgresql-pl-8.1.10-1PGDG.rhel4.i686

IIRC, libperl.so is installed by perl itself -- isn't is there?

>           libpython2.3.so.1.0 is needed by
>   postgresql-pl-8.1.10-1PGDG.rhel4.i686

and this is supplied by python RPM.

Both perl and python packages are among the default installation package
group of Red Hat, IIRC. I can understand that perl is uninstallable, but
python cannot thinking that yum depends on it :)

...and just a reminder: If you don't need PL/Python and PL/Perl, you
don't need to install that package.

Regards,

-- 
Devrim GÜNDÜZ , RHCE
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, ODBCng - http://www.commandprompt.com/

In response to

Responses

pgsql-novice by date

Next:From: Tom LaneDate: 2007-11-13 02:47:36
Subject: Re: postgresql 8.1.10-1PGDG (32 bit) installaion on RHEL 4
Previous:From: Kasia TuszynskaDate: 2007-11-12 23:23:54
Subject: Re: Autovacuum - what does it actually do?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group