Skip site navigation (1) Skip section navigation (2)

Re: referential integrity violation - key referenced from

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: "Luiz Henrique" <luizhwk(at)gmail(dot)com>
Cc: "Jim Nasby" <jnasby(at)pervasive(dot)com>, "Stephan Szabo" <sszabo(at)megazone(dot)bigpanda(dot)com>, pgsql-bugs(at)postgresql(dot)org
Subject: Re: referential integrity violation - key referenced from
Date: 2006-08-22 21:18:40
Message-ID: 11815.1156281520@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-bugs
"Luiz Henrique" <luizhwk(at)gmail(dot)com> writes:
> On 8/21/06, Jim Nasby <jnasby(at)pervasive(dot)com> wrote:
>> What version are you using? In recent versions, indexes are supposed
>> to be safe from corruption, even through crashes.

> It's Postgresql 7.2.1, installed with stable version of Debian Woody, at the
> time.

7.2.1 is ancient and has a very long list of known bugs.  We officially
abandoned support for the 7.2.* branch more than a year ago, upon
finding some bugs that were simply not practical to fix in that branch.

If you must keep using 7.2.*, at least get yourself onto 7.2.8, the last
of that series.  But you'd be doing yourself a real favor by expending
a little more effort and moving to a current release series ---
preferably 8.1.*.

			regards, tom lane

In response to

pgsql-bugs by date

Next:From: Peter EisentrautDate: 2006-08-22 21:30:58
Subject: Re: [BUGS] BUG #2585: Please provide pkg-config support
Previous:From: Tom LaneDate: 2006-08-22 20:24:36
Subject: Re: BUG #2585: Please provide pkg-config support

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group