Skip site navigation (1) Skip section navigation (2)

compile problems

From: Giuseppe Sacco <giuseppe(at)eppesuigoccas(dot)homedns(dot)org>
To: pgadmin-hackers(at)postgresql(dot)org
Subject: compile problems
Date: 2007-04-22 11:08:20
Message-ID: 1177240100.5388.7.camel@scarafaggio (view raw or flat)
Thread:
Lists: pgadmin-hackers
Hi all,
I am recompiling pgAdmin from SVN since I would like to check my updated
translation, but I get these errors:

if gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include/postgresql -DSSL
-I/usr/local/wxWidgets-2.8.2/lib/wx/include/gtk2-unicode-release-2.8
-I/usr/local/wxWidgets-2.8.2/include/wx-2.8 -D_FILE_OFFSET_BITS=64
-D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D__WXGTK__ -O2
-I/usr/include/libxml2 -I/usr/include/libxml2 -DDATA_DIR=
\"/usr/loca/pgadmin3-1.8.2/share/pgadmin3/\" -Wall -I../pgadmin/include
-MT keywords.o -MD -MP -MF ".deps/keywords.Tpo" -c -o keywords.o `test
-f './db/keywords.c' || echo './'`./db/keywords.c; \
        then mv -f ".deps/keywords.Tpo" ".deps/keywords.Po"; else rm -f
".deps/keywords.Tpo"; exit 1; fi
In file included from ./db/keywords.c:22:
gram.y:122: error: expected specifier-qualifier-list before ‘JoinType’
make[2]: *** [keywords.o] Error 1

anyone knows what's wrong?

Thanks,
Giuseppe

Responses

pgadmin-hackers by date

Next:From: Guillaume LelargeDate: 2007-04-22 13:45:26
Subject: Re: compile problems
Previous:From: Giuseppe SaccoDate: 2007-04-22 07:46:40
Subject: Re: Google Summer of Code

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group