As commented by Peter, I have done some re-styling.
Some additional tests and format checking have been added to this patch.
> Put your file at the end of the OBJS variable (or in some sort of
> sensible order).
> Put your file at the end of the tests (or in some sort of sensible
> Refrain from self-evident comments, such as
> + /*
> + * function handles input for the uuid datatype
> + */
> + Datum uuid_in(PG_FUNCTION_ARGS)
> You can probably delete all comments in your patch by that criterion.
Some changed, but not all has been removed for readability reasons.
> This sort of super-verbose coding might be alright, but it gets tiring
> when done systematically for no reason:
> + result = DirectFunctionCall1(textin, uuid_str);
> + return result;
Some changed, but not all.
> The uuid.c file claims it is uuid.h.
> Move the stuff from builtins.h to uuid.h.
Not changed. please see:
> Move the stuff from uuid.h that is not needed anywhere else to uuid.c.
> No // comments.
> Don't number the tests. We might want to insert something later and
> that would mess everything up.
> Capitalize the SQL test scripts as in other files.
> Remove gratuitous whitespace changes (there are many).
> Also remove the whitespace at the end of lines.
> Make some reasonable effort to align the catalog entries for
Any more comments?
In response to
pgsql-patches by date
|Next:||From: Greg Sabino Mullane||Date: 2007-01-26 14:08:50|
|Subject: Re: pg_dump pretty_print|
|Previous:||From: Magnus Hagander||Date: 2007-01-26 11:53:39|
|Subject: Re: Getting rid of warnings|