Skip site navigation (1) Skip section navigation (2)

libgda/libgnomedb 1.9.99 released

From: Rodrigo Moya <rodrigo(at)gnome-db(dot)org>
To: GDA <gnome-db-list(at)gnome(dot)org>
Cc: gnome-office-list(at)gnome(dot)org, gnome-announce-list(at)gnome(dot)org,pgsql-announce(at)postgresql(dot)org, announce(at)lists(dot)mysql(dot)org
Subject: libgda/libgnomedb 1.9.99 released
Date: 2005-09-26 10:28:44
Message-ID: 1127730524.9467.10.camel@cerler.home (view raw or flat)
Thread:
Lists: pgsql-announce
libgda/libgnomedb are a complete framewok for developing
database-oriented applications, and currently allow access to PostgreSQL,
MySQL, Oracle, Sybase, SQLite, FireBird/Interbase, IBM DB2, mSQL and MS
SQL server, as well as MS Access and xBase files and ODBC data sources.
                                                                                
libgda/libgnomedb are the base of the database support in the GNOME
Office application suite, providing database access for many features in
both Gnumeric and Abiword.

1.9.99 is the latest RC before final 2.0.0

Changes since libgda 1.3.91
---------------------------
 - Added Mono bindings from GTK# (Dan)
 - Convert SQLstate to GDA error code in PostgreSQL provider (Juan Manuel)
 - Don't use scrollkeeper for API docs (Rodrigo)
 - Improved data types in SQLite provider (Vivien)
 - API fixes (Vivien, Murray)
 - Removed unfinished, non-working objects (Vivien)
 - Blob object fixes (Vivien)
 - Blob improvements in PostgreSQL provider (Vivien)
 - Improved test to locate MDB libraries (Vivien)
 - Added "gda_type_changed" signal to GdaColumn (Vivien)
 - Updated translations:
        - eu (Iñaki)
        - ne (Pawan)
	- vi (Clytie)

Changes since libgnomedb 1.3.91
-------------------------------
 - Compilation fixes (Rodrigo, Stanislav)
 - Added Mono bindings from GTK# (Dan)
 - Install plugins in $libdir (Stanislav)
 - Added SQL console menu item to browser application (Vivien)
 - Fixed row numbers status messages in browser application (Vivien)
 - Fixed compilations flags and libs for sample application (Juan Manuel)
 - Extended GnomeDbSelector API (Vivien)
 - Adapted to libgda-1.9.99 API changes (Vivien, Rodrigo)
 - Updated translations:
        - en_CA (Adam)
        - eu (Iñaki)
        - ne (Pawan)
	- vi (Clytie)

Tarballs are available at
http://download.gnome.org/pub/GNOME/sources/libgda/1.9/
http://download.gnome.org/pub/GNOME/sources/libgnomedb/1.9/
                                                                                
To install this new version, you'll need:
* libgda: glib, libxml2, libxslt
* libgnomedb: libgda and dependencies, libgnome/ui, libglade,
libbonoboui and, optionally, gtksourceview
                                                                                
You can find more information at the projects' homepage
(http://www.gnome-db.org), or you can ask any question/propose anything
you want in the GNOME-DB mailing list, which is available at
http://mail.gnome.org/mailman/listinfo/gnome-db-list.

-- 
Rodrigo Moya <rodrigo(at)gnome-db(dot)org>


pgsql-announce by date

Next:From: Josef SpringerDate: 2005-09-27 14:04:34
Subject: New variant of BPM-System OfficeTalk available for PostgreSQL
Previous:From: David FetterDate: 2005-09-26 02:13:13
Subject: == PostgreSQL Weekly News - September 25 2005 ==

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group