Skip site navigation (1) Skip section navigation (2)

Re: problems installing pgsql on rh9 box

From: Jeff MacDonald <jam(at)zoidtechnologies(dot)com>
To: Ricardo Gamero <ricardo(dot)gamero(at)gmail(dot)com>
Cc: pgsql-hackers(at)postgresql(dot)org
Subject: Re: problems installing pgsql on rh9 box
Date: 2005-08-30 22:12:21
Message-ID: 1125439941.2923.20.camel@eros.zoidtechnologies.com (view raw or flat)
Thread:
Lists: pgsql-hackers
On Tue, 2005-08-30 at 12:06 -0600, Ricardo Gamero wrote:
> Hello everybody!
>  
> I'm so sorry to post this simple question but I don't know what to do,
> the thing is I need to install postgresql 8.0.3 in red hat 9 but when
> I try to do it this errors appear:
>  
> [root(at)bib root]# rpm -ivh postgresql-server-8.0.3-1PGDG.i686.rpm
> warning: postgresql-server-8.0.3-1PGDG.i686.rpm: V3 DSA signature:
> NOKEY, key ID 748f7d0e
> error: Failed dependencies:
>         libcrypto.so.4 is needed by postgresql-server-8.0.3-1PGDG
>         libpq.so.4 is needed by postgresql-server-8.0.3-1PGDG
>         libssl.so.4 is needed by postgresql-server-8.0.3-1PGDG
>         postgresql = 8.0.3 is needed by postgresql-server-8.0.3-1PGDG 
>         postgresql < 7.4 conflicts with postgresql-server-8.0.3-1PGDG
>  

greetings,

I tried this on the (only) rh9 box I have, and I had similar dependency
issues. note that I used '-Uvh' instead of '-ivh' but I got the
following:

[~] [6:05pm] [aristotle] % ls postgresql-*.rpm
postgresql-8.0.3-1PGDG.i686.rpm
postgresql-libs-8.0.3-1PGDG.i686.rpm
postgresql-server-8.0.3-1PGDG.i686.rpm
postgresql-devel-8.0.3-1PGDG.i686.rpm
postgresql-pl-8.0.3-1PGDG.i686.rpm

[~] [6:05pm] [aristotle] % sudo rpm -Uvh postgresql-*.rpm
Password:
warning: postgresql-8.0.3-1PGDG.i686.rpm: V3 DSA signature: NOKEY, key
ID 748f7d0e
error: Failed dependencies:
        libecpg.so.4 is needed by postgresql-libs-8.0.3-1PGDG
        libpgtypes.so.1 is needed by postgresql-libs-8.0.3-1PGDG
        libpq.so.3 is needed by postgresql-libs-8.0.3-1PGDG

in the original version that I have installed on my rh9 box, libpq.so.3
is provided by postgresql-libs, but as you can see from the above I
tried installing that and I still get the dependency problems.

regards,
J

In response to

pgsql-hackers by date

Next:From: Satoshi NagayasuDate: 2005-08-30 23:32:12
Subject: Re: Pre-allocated free space for row updating (like PCTFREE)
Previous:From: Chris BrowneDate: 2005-08-30 22:08:47
Subject: Re: [Slony1-general] Re: dangling lock information?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group