Skip site navigation (1) Skip section navigation (2)

Error while installing Slony 1.1.0 for PostGreSql version 7.3.4

From: Ajay Dalvi <dalvi_ajay(at)extenprise(dot)net>
To: pgsql-general(at)postgresql(dot)org
Subject: Error while installing Slony 1.1.0 for PostGreSql version 7.3.4
Date: 2005-06-30 13:51:15
Message-ID: 1120139475.22743.36.camel@paloalto (view raw or flat)
Thread:
Lists: pgsql-general
Hello All,
   I am from India - Pune


I have PostGreSql 7.3.4 installed on RedHat Linux 9.

I want to do the Replication on PostGreSql databases

I am going to use Slony 1.1.0 for Replication.

I am follwing the installation steps that are given in
Slony-I-Install.txt in Slony 1.1.0 source.


But while installing , during configuration step i am getting an error

error: Your version of libpq doesn't have PQunescapeBytea
     this means that your version of PostgreSQL is lower than 7.3
     and thus not supported by Slony-I.
     
Though i am having PostGreSql Version 7.3.4, this error is comming.

So if anyone is having any solution about this error please let me know
as soon as possible


Following is the output that is geting displayed after running
'configure' file
--with-pgconfigdir represents path of the 'pg_config' utility.


[root(at)paloalto slony1-1.1.0]# ./configure --with-pgconfigdir=/usr/bin
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking which template to use... linux
configure: using CFLAGS=
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for perl... /usr/bin/perl
checking for tar... /bin/tar
checking for flex... flex
checking for bison... bison -y
checking for sed... sed
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... no
checking for cc_r... gcc
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking limits.h usability... yes
checking limits.h presence... yes
checking for limits.h... yes
checking stddef.h usability... yes
checking stddef.h presence... yes
checking for stddef.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for inttypes.h... (cached) yes
checking for gettimeofday... yes
checking for dup2... yes
checking for alarm... yes
checking for memset... yes
checking for select... yes
checking for strdup... yes
checking for strerror... yes
checking for strtol... yes
checking for strtoul... yes
checking for int32_t... yes
checking for uint32_t... yes
checking for u_int32_t... yes
checking for int64_t... yes
checking for uint64_t... yes
checking for u_int64_t... yes
checking for ssize_t... yes
checking for POSIX signal interface... yes
checking for pg_config... /usr/bin/pg_config
checking for correct version of PostgreSQL... 7.3
checking for PQunescapeBytea in -lpq... no
configure: error: Your version of libpq doesn't have PQunescapeBytea
     this means that your version of PostgreSQL is lower than 7.3
     and thus not supported by Slony-I.



Regards,
-Ajay Dalvi



Responses

pgsql-general by date

Next:From: David GagnonDate: 2005-06-30 13:57:48
Subject: Re: Explain Analyse never returns .. maybe a bug
Previous:From: Jason TesserDate: 2005-06-30 13:15:47
Subject: Re: Possible move away from PG

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group