Skip site navigation (1) Skip section navigation (2)

Re: bajar la version 7.4.6 en rpm listo pararedhat 7.3

From: Edgard Pineda <epineda(at)newtenberg(dot)com>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: bajar la version 7.4.6 en rpm listo pararedhat 7.3
Date: 2004-11-25 15:48:00
Message-ID: 1101397679.15937.24.camel@aukinko.ntg.cl (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
El jue, 25-11-2004 a las 11:36, Alvaro Herrera escribió:
> On Thu, Nov 25, 2004 at 11:24:35AM -0300, Edgard Pineda wrote:
> 
> > 	mirando los mirrors de postgres solo encontré hasta la versión 7.4.1
> > binarios de rpms listos para redhat 7.3
> > 	hay algún lugar que se hayan apiadado con los que usan redhat 7.3
> > dejando los rpms de la versión 7.4.6 listos para instalar?
> 
> Esa distribucion todavia existe?
> 
> Si no hay RPMS, puedes tomar los SRPMS y reconstruir.  Es trivial de
> hacer ...

Estando en un redhat 7.3 parchado al dia con fedoralegacy, bajé:
ftp://ftp8.us.postgresql.org/postgresql/binary/v7.4.6/srpms/redhat/redhat-9/postgresql-7.4.6-2PGDG.src.rpm
ejecuté el rpm -i sobre él, luego edité
/usr/src/redhat/SPECS/postgresql.....spec
agregué en la primera línea %define build7x 1
(luego de echarle una mirada al spec y cachar un poco lo que hacía)
luego un rpm -ba sobre el .spec y error (ultimas líneas):

checking for Perl privlibexp... /usr/lib/perl5/5.6.1
checking for Perl useshrplib... false
checking for flags to link embedded Perl...   -L/usr/local/lib
/usr/lib/perl5/5.6.1/i386-linux/auto/DynaLoader/DynaLoader.a
-L/usr/lib/perl5/5.6.1/i386-linux/CORE -lperl -lnsl -ldl -lm -lc -lcrypt
-lutil
checking for python... /usr/bin/python
checking Python installation directories... Traceback (innermost last):
  File "<string>", line 1, in ?
ImportError: No module named distutils
Traceback (innermost last):
  File "<string>", line 1, in ?
ImportError: No module named distutils
/usr/
checking how to link an embedded Python application... no
configure: error: Python Makefile not found
error: Bad exit status from /var/tmp/rpm-tmp.84442 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.84442 (%build)

me faltará algún modulo en el python o rpm?... o algo más grave:
necesito una versión mayor de python (no creo, al ver el .spec se ve que
verifica versión...) ??

gracias por toda ayuda,
Edgard.


In response to

Responses

pgsql-es-ayuda by date

Next:From: Ronald Correa MaciasDate: 2004-11-25 15:59:07
Subject: Conexion simultanea a dos bases de datos
Previous:From: Patricio MuñozDate: 2004-11-25 15:45:29
Subject: Re: bajar la version 7.4.6 en rpm listo para redhat 7.3

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group