Skip site navigation (1) Skip section navigation (2)

probs with 7.3 -> 7.4 on debian

From: glenn <gdavy(at)tpg(dot)com(dot)au>
To: "pgsql-novice(at)postgresql(dot)org" <pgsql-novice(at)postgresql(dot)org>
Subject: probs with 7.3 -> 7.4 on debian
Date: 2004-01-14 14:47:25
Message-ID: 1074091644.4094.9.camel@odin.valhalla (view raw or flat)
Thread:
Lists: pgsql-novice
Hi all
Debian has upgraded me to 7.4 ofpostgres, but when it tries to  start
postgres I get an error mentioning that the data is in 7.3 format and
needs to be upgraded to 7.4 format before postmaster will start.


"dpkg-reconfigure postgresql" attempts to do just this for me, but fails
during upgrade.

so I follow the instructions in README.Debian.migration like so:

odin:~# su -s /bin/bash - postgres
postgres(at)odin:~$ postgresql-dump -t db.out -dcivlp $PGDATA/../data.save
Stopping and restarting the postmaster
/var/lib/postgres/dumpall/7.3/postmaster -D /var/lib/postgres/data  -p
5431 -o -d0
/var/lib/postgres/dumpall/7.3/postmaster: error while loading shared
libraries: libcom_err.so.1: cannot open shared object file: No such file
or directory
Failed to start the postmaster
postgres(at)odin:~$

Is any one able to point me the right way from here?
Thanks 
Glenn


Responses

pgsql-novice by date

Next:From: Oliver ElphickDate: 2004-01-14 15:08:22
Subject: Re: probs with 7.3 -> 7.4 on debian
Previous:From: Aarni RuuhimäkiDate: 2004-01-14 14:19:14
Subject: SQL_ASCII / LATIN1

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group