Skip site navigation (1) Skip section navigation (2)

Re: [pgadmin-support] using Debian Sid

From: Aurélien Campéas <aurelien(dot)aa(at)wanadoo(dot)fr>
To: Raphaël Enrici <blacknoz(at)club-internet(dot)fr>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: [pgadmin-support] using Debian Sid
Date: 2004-01-09 12:19:10
Message-ID: 1073650749.963.15.camel@orangebud.budies.freedom (view raw or flat)
Thread:
Lists: pgadmin-hackerspgadmin-support
Le ven 09/01/2004 à 00:34, Raphaël Enrici a écrit :
> Hi Andreas,
> 
> concerning this problem we exchanged some mail with Aurélien and 
> couldn't find any reason why this window is not displayed correctly on 

Note that my (girl)-friend has the same system, only more recently setup
and it does not exhibit the problem. I would bet it is an extremely rare
and obnoxious condition that causes it. I dare suggest it is not really
worth spending time tracking it (gee, recently I've had problems with
slow Mozilla *shutdowns*).

> its system. Any Idea of where we could start from ? I tried to get a 
> system configured as near as I could from his own one, but I still can't 
> reproduce the bug.

I strongly suspect it comes from src/unix/mimetype.cpp code from wxWin.
There's code there that tries to guess what are the mime types
definitions from *various* source in the system, and guess what, on a
heavily loaded debian sid, there can be many. Strangely, the process of
parsing/analyzing/frobnicating those files takes maybe a longer time
that "could" be...

> 
> Another thing which Aurélien told me and which is reproducable in some 
> cases 

albeit version 1.0.2 does not shows this on win2k - I didn't test the
snapshot version in that case

> is a high CPU consumption when opening the preferences/options for 
> the first time (it takes approximatively 90% cpu for about 1 or 2 
> seconds on my athlon XP2000+ and about 5 seconds 100%CPU on its athlon 
> 700)... As far as I could test, it seems to be linked with the packages 
> installed : on a minimal system I can't observe this.

minimal, like win2k ?-)

I suspect it is related to the wxWin routines mentioned above, too, as
the strace shows (storm of stat64(), brk(), and fork() )

I hope this helps.

> 
> Any Idea ? How does it looks like on other distros ?
> 
> Regards,
> Raphaël
> 
> Aurélien Campéas wrote:
> 
> >Want a snapshot ? Have it :)
> >
> >Le mar 16/12/2003 à 20:04, Andreas Pflug a écrit :
> >  
> >
> >>Aurélien Campéas wrote:
> >>
> >>    
> >>
> >>>Seems like 1.1 has the same problems. 
> >>>Also, the log level is not selectable from the GUI (there's nothing to
> >>>click on, just a gray empty panel).
> >>> 
> >>>
> >>>      
> >>>
> >>?!?!?
> >>Nothing to be seen from file/options?
> >>Never heard something like that.
> >>
> >>Regards,
> >>Andreas
> >>    
> >>
> >A kind of Batman of contemporary letters. -- Philip Larkin on Anthony
> >Burgess
> >  
> >
> >
> > ------------------------------------------------------------------------
> >
> >------------------------------------------------------------------------
> >
> >
> >---------------------------(end of broadcast)---------------------------
> >TIP 4: Don't 'kill -9' the postmaster
> >  
> >
There is a 20% chance of tomorrow.


In response to

pgadmin-hackers by date

Next:From: Devrim GUNDUZDate: 2004-01-13 08:49:04
Subject: Build Error on FC1
Previous:From: Raphaël EnriciDate: 2004-01-08 23:34:15
Subject: Re: [pgadmin-support] using Debian Sid

pgadmin-support by date

Next:From: bvolDate: 2004-01-09 22:09:38
Subject: unsubscribe
Previous:From: Raphaël EnriciDate: 2004-01-08 23:34:15
Subject: Re: [pgadmin-support] using Debian Sid

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group