Skip site navigation (1) Skip section navigation (2)

gcc libpthread problem with latest Slackware snapshot

From: "Keith C(dot) Perry" <netadmin(at)vcsn(dot)com>
To: pgadmin-support(at)postgresql(dot)org
Subject: gcc libpthread problem with latest Slackware snapshot
Date: 2003-12-23 16:25:34
Message-ID: 1072196734.3fe86c7e14cfa@webmail.vcsn.com (view raw or flat)
Thread:
Lists: pgadmin-support
I just upgraded from the 10/29 snapshot to the 12/22 one and when I try to run
the app, I get this:

bash-2.05b# pgadmin3 
pgadmin3: /lib/libpthread.so.0: version `GLIBC_2.3.2' not found (required by
pgadmin3)


Here are the vitals:

Slackware 9.0 with Kernel 2.4.22 (compiled)

bash-2.05b# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-slackware-linux/3.2.2/specs
Configured with: ../gcc-3.2.2/configure --prefix=/usr --enable-shared
--enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld
--verbose --target=i386-slackware-linux --host=i386-slackware-linux
Thread model: posix
gcc version 3.2.2


bash-2.05b# ldconfig -p | grep libpthread
        libpthread.so.0 (libc6, OS ABI: Linux 2.0.0) => /lib/libpthread.so.0
        libpthread.so (libc6, OS ABI: Linux 2.0.0) => /usr/lib/libpthread.so


Based on my ldconfig, it look like the problem is the gcc version.

In the meantime, I guess I'm just use somethings closer to the 10/29 version.



-- 
Keith C. Perry, MS E.E.
Director of Networks & Applications
VCSN, Inc.
http://vcsn.com
 
____________________________________
This email account is being host by:
VCSN, Inc : http://vcsn.com

pgadmin-support by date

Next:From: Dave PageDate: 2003-12-23 17:01:13
Subject: Re: gcc libpthread problem with latest Slackware snapshot
Previous:From: Constantin StefanovDate: 2003-12-23 08:52:06
Subject: Estimated rowcount bug not fixed in pgadmin3 1.0.2.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group