Skip site navigation (1) Skip section navigation (2)

Re: `make depend' broken in CVS sources

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Peter Eisentraut <peter_e(at)gmx(dot)net>
Cc: Ian Lance Taylor <ian(at)airs(dot)com>, pgsql-hackers(at)postgresql(dot)org
Subject: Re: `make depend' broken in CVS sources
Date: 2001-04-30 05:16:09
Message-ID: 10677.988607769@sss.pgh.pa.us (view raw or flat)
Thread:
Lists: pgsql-hackers
Peter Eisentraut <peter_e(at)gmx(dot)net> writes:
> Ian Lance Taylor writes:
>> `make depend' is broken in the CVS sources.

> 'make depend' doesn't exist anymore.  Use configure --enable-depend.

However, the makefiles are still full of depend targets --- so someone
who hadn't read the configure docs with eagle eyes could be forgiven
for thinking that 'make depend' will do what it usually does in most
other project trees.

Perhaps in the next release the make targets should be renamed to
something other than depend.  At the very least, it'd be nice if
'make depend' at the top level would emit a helpful error message
rather than doing something obscure/wrong.

			regards, tom lane

In response to

pgsql-hackers by date

Next:From: Tom LaneDate: 2001-04-30 05:58:38
Subject: Re: WAL performance with wal_sync_method = open_sync
Previous:From: The Hermit HackerDate: 2001-04-30 04:57:57
Subject: Re: v7.1 error ... SELECT converted to a COPY?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group