Skip site navigation (1) Skip section navigation (2)

RE: initdb problem...

From: "chris markiewicz" <cmarkiew(at)commnav(dot)com>
To: "'Jason Tishler'" <Jason(dot)Tishler(at)dothill(dot)com>
Cc: <pgsql-ports(at)postgresql(dot)org>, <chris(dot)markiewicz(at)commnav(dot)com>
Subject: RE: initdb problem...
Date: 2001-04-12 13:26:48
Message-ID: 013f01c0c354$3aa38cc0$dbb846c6@cmarkiewicz (view raw or flat)
Thread:
Lists: pgsql-ports
Jason,

uname -r returns 1.3.0s(0.37/3/2)

is that significant?

Looks like we're still having the same problem, even after grabbing the most
recent dll and changing our PGDATA value.

you are correct that i am not doing any building of my own (i have neither
the tools nor the expertise).

thanks for the help, btw.

chris

-----Original Message-----
From: Jason Tishler [mailto:Jason(dot)Tishler(at)dothill(dot)com]
Sent: Wednesday, April 11, 2001 5:49 PM
To: chris markiewicz
Cc: pgsql-ports(at)postgresql(dot)org; chris(dot)markiewicz(at)commnav(dot)com
Subject: Re: [PORTS] initdb problem...


Chris,

On Wed, Apr 11, 2001 at 02:35:07PM -0400, chris markiewicz wrote:
> we have been trying to run postgres on a win2000 machine.  got the latest
> cygwin stuff today (4/11/2001) and installed it.  initdb hangs.  i checked
> the archives and found the following thread (the following link has the
> final leaf of the thread):

What does uname -r display?  If it indicates "1.1.8...", then you must
upgrade to a recent snapshot.

> http://www.postgresql.org/mhonarc/pgsql-ports/2001-03/msg00124.html

The above is only relevant *if* you are building PostgreSQL yourself --
not if you are using a pre-built version.

Just to be sure, are you using the 7.1rc4 that I contributed to Cygwin?

> i also have debug information (see end of email).

Sorry, but I can't make much out of your debug info.

> Does all of this mean that i need to grab a recent development snapshot of
> the cygwin1.dll file?

Most likely, see the following for one way of replacing your Cygwin DLL:

    http://www.postgresql.org/mhonarc/pgsql-ports/2001-03/msg00096.html

> IF SO...(i know this is a question for cygwin, but since we're here) i go
to
> the snapshot area and click on the ftp link and i get a "page cannot be
> displayed" message.  what am i doing wrong?

No one can download from the Cygwin FTP site anymore.  You must use a
mirror.  Try the following:

    ftp://mirrors.rcn.net/mirrors/sources.redhat.com/cygwin/snapshots/

> Running with debug mode on.
>
> Initdb variables:
>   PGDATA=/usr/bin/data

BTW, the above is a strange value for PGDATA.  I would use
/usr/share/postgresql/data instead.

Jason

--
Jason Tishler
Director, Software Engineering       Phone: +1 (732) 264-8770 x235
Dot Hill Systems Corp.               Fax:   +1 (732) 264-8798
82 Bethany Road, Suite 7             Email: Jason(dot)Tishler(at)dothill(dot)com
Hazlet, NJ 07730 USA                 WWW:   http://www.dothill.com


In response to

Responses

pgsql-ports by date

Next:From: Jason TishlerDate: 2001-04-12 13:34:09
Subject: Re: initdb problem...
Previous:From: kevin mclaughlinDate: 2001-04-12 02:28:56
Subject: Fw: porting to AIX

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group