Skip site navigation (1) Skip section navigation (2)

Re: Upgrade to 7.1.2 problem

From: Lamar Owen <lamar(dot)owen(at)wgcr(dot)org>
To: "Kannan The Barbarian" <swamy3(at)lycos(dot)com>, pgsql-bugs(at)postgresql(dot)org
Subject: Re: Upgrade to 7.1.2 problem
Date: 2001-07-13 18:19:58
Message-ID: 01071314195800.00944@lowen.wgcr.org (view raw or flat)
Thread:
Lists: pgsql-bugs
On Wednesday 11 July 2001 13:57, Kannan The Barbarian wrote:
> i recently upgraded to postgresql-7.1.2 but when i start the service, i get
> the folllowing error message!

> An old version of the database format was found.\nYou need to upgrade the
> data format before using PostgreSQL.\nSee /
> usr/share/doc/postgresql-7.1.2/README.rpm-dist for more information.

> As far as i know the old databases have been upgraded! Whatsover, if there
> are any other databases in there and i dont want any of those older
> databases, what do i do!

Check to see where it thinks the old data is -- 'it' being the RPM init 
script that is issuing that error message.

The two choices of a default RPM install are /var/lib/pgsql and 
/var/lib/pgsql/data -- you need to remove the whole tree, leaving 
/var/lib/pgsql/data and /var/lib/pgsql/backups left empty.

Now rerun the initscript, and it will happily create a new,empty, database 
tree for you that you can start working with.
--
Lamar Owen
WGCR Internet Radio
1 Peter 4:11

In response to

pgsql-bugs by date

Next:From: Stephan SzaboDate: 2001-07-13 18:25:45
Subject: Re: No subselects in constraint (bug?)
Previous:From: The Hermit HackerDate: 2001-07-13 17:56:49
Subject: Re: your web site register is broken, cannot download Win32 distribution needed

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group