Skip site navigation (1) Skip section navigation (2)

Re: Connection Problem

From: "Joseph Watson" <jtwatson(at)datakota(dot)com>
To: "pgsql-ODBC \(E-mail\)" <pgsql-ODBC(at)postgresql(dot)org>
Subject: Re: Connection Problem
Date: 2002-01-27 04:46:25
Message-ID: 00e001c1a6ed$94576520$0a01a8c0@bay.chartermi.net (view raw or flat)
Thread:
Lists: pgsql-odbc
 > > -----Original Message-----
 > > From: Joseph Watson [mailto:jtwatson(at)datakota(dot)com]
 > >
 > > Here is the Mylog debug output.  Hope it helps, thanks for the help.
 >
 > I see no suspicios error in the log.
 > When(where) does your error occur ?
 >
 > regards,
 > Hiroshi Inoue
 >


     I don't see anything funny in any of the logs myself.  In the
PostgreSQL
 log, it shows that the connection was successfull, and some default quiries
 are executed and all looks good.  Likewise in the logges generated by the
 ODBC driver, all look okay.  It seems to me that what ever is returned to
 VB from the ODBC driver is not of the right data type.

 Here is my VB code:

 Private Sub Command5_Click()

     Dim FSEInfo As Workspace
     Dim conn As Connection
     Dim connstring As String

     connstring = "ODBC;DSN=FSE Info;"

     Set FSEInfo = CreateWorkspace("FSE_Info_ws", txtUser, txtPassword,
 dbUseODBC)

     Set conn = FSEInfo.OpenConnection("FSE_Info_cnn",
 dbDriverCompleteRequired, False, connstring)

     conn.Close

     FSEInfo.Close

 End Sub

 The error occurs on the "Set Conn" line, and reads:


     Run-time error '13':

     "type mismatch"

 and here is the log from PostgreSQL,

 2002-01-26 06:25:39 DEBUG:  connection: host=192.168.1.10 user=jtwatson
 database=fseinfo
 2002-01-26 06:25:39 DEBUG:  query: set DateStyle to 'ISO'
 2002-01-26 06:25:39 DEBUG:  ProcessUtility: set DateStyle to 'ISO'
 2002-01-26 06:25:39 DEBUG:  query: set geqo to 'OFF'
 2002-01-26 06:25:39 DEBUG:  ProcessUtility: set geqo to 'OFF'
 2002-01-26 06:25:39 DEBUG:  query: set ksqo to 'ON'
 2002-01-26 06:25:39 DEBUG:  ProcessUtility: set ksqo to 'ON'
 2002-01-26 06:25:39 DEBUG:  query: select oid from pg_type where
 typname='lo'
 2002-01-26 06:25:39 DEBUG:  query: select version()

 It lookes like the connection was successful and there was 5 successfull
 queries made.  But I get a error dialog popup in access saying type
mismatch
 error.  It seems that the data returned to VB by the ODBC driver is being
 rejected by the connection data type???

 I attached a Access 2000 database that will reproduce this problem.  Just
 edit the DSN to match one on your machine.

 Thanks for the help thus far.


 Joseph


Attachment: db1.mdb
Description: application/msaccess (108.0 KB)

pgsql-odbc by date

Next:From: Ludek FinstrleDate: 2002-01-27 21:47:06
Subject: SQLExecute get result to client?
Previous:From: Joseph WatsonDate: 2002-01-26 23:38:59
Subject: Re: Connection Problem

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group