Skip site navigation (1) Skip section navigation (2)

Re: libpq.so.3 compatability problem still there for 8.0.3 installs

From: "Gregory Zelesnik" <gzelesnik(at)comcast(dot)net>
To: "'Devrim GUNDUZ'" <devrim(at)gunduz(dot)org>
Cc: <pgsql-admin(at)postgresql(dot)org>
Subject: Re: libpq.so.3 compatability problem still there for 8.0.3 installs
Date: 2005-07-28 18:53:39
Message-ID: 005601c593a5$af3e74c0$6401a8c0@rocco (view raw or flat)
Thread:
Lists: pgsql-admin
Devrim,

Thank you so much for replying.

Actually, I do not have postgresql-libs v8.0.2 installed:

[gzelesnik(at)linus downloads]$ rpm -qa | grep postgres
rh-postgresql-devel-7.3.6-7
rh-postgresql-tcl-7.3.6-7
postgresql-docs-8.0.3-1PGDG
rh-postgresql-pl-7.3.6-7
rh-postgresql-libs-7.3.6-7
rh-postgresql-7.3.6-7
rh-postgresql-test-7.3.6-7
postgresql-jdbc-8.0.3-1PGDG
rh-postgresql-python-7.3.6-7
rh-postgresql-contrib-7.3.6-7
rh-postgresql-server-7.3.6-7
postgresql-odbc-7.3-3

------

And when I try to upgrade postgresql-libs v7.3.6-7 to v8.0.3, I get the
following conflicts:

[gzelesnik] rpm -Uv postgresql-libs-8.0.3-1PGDG.i686.rpm
error: Failed dependencies:
        libecpg.so.4 is needed by postgresql-libs-8.0.3-1PGDG
        libpgtypes.so.1 is needed by postgresql-libs-8.0.3-1PGDG
        libpq.so.3 is needed by postgresql-libs-8.0.3-1PGDG
        libpq.so.3 is needed by (installed) xemacs-21.4.13-8.ent
        libpq.so.3 is needed by (installed) mod_auth_pgsql-2.0.1-4.ent
        libpq.so.3 is needed by (installed) php-pgsql-4.3.2-14.ent
        libpq.so.3 is needed by (installed) perl-DBD-Pg-1.21-2
        libpq.so.3 is needed by (installed) rh-postgresql-python-7.3.6-7
        libpq.so.3 is needed by (installed) rh-postgresql-tcl-7.3.6-7
        libpq.so.3 is needed by (installed) rh-postgresql-7.3.6-7
        libpq.so.3 is needed by (installed)
rh-postgresql-contrib-7.3.6-7
        libpq.so.3 is needed by (installed) rh-postgresql-server-7.3.6-7
        postgresql-libs = 7.3.6 is needed by (installed)
rh-postgresql-devel-7.3.6-7
    Suggested resolutions:
        rh-postgresql-libs-7.3.6-7.i386.rpm

----

The conflict seems to be embedded in the set of packages for v8.0.3, and
the compat-postgresql-libs-3-3PGDG.rpm package doesn't seem to like
trying to upgrade from 7.3.6.

Any ideas?

Thank you!

Sincerely,
Greg

-----Original Message-----
From: Devrim GUNDUZ [mailto:devrim(at)gunduz(dot)org] 
Sent: Wednesday, July 27, 2005 5:32 PM
To: Gregory Zelesnik
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: [ADMIN] libpq.so.3 compatability problem still there for
8.0.3 installs


Hi,

On Wed, 27 Jul 2005, Gregory Zelesnik wrote:

> I'm trying to upgrade to postgreSQL 8.0.3-1 from 7.3.6-7.  I'm having
> the same compatibility problem with libpq.so.3 that others seem to be
> having.
> After searching the web, I noticed that the solution seemed to be to
> download the compatibility package:
> compat-postgresql-libs-3-3PGDG.i686.rpm and install this first..
>
> I've downloaded it, and my attempt to install it produced the
following
> conflict:
>
> error: Failed dependencies:
>        postgresql-libs < 8.0.2 conflicts with
> compat-postgresql-libs-3-3PGDG
>
> Can anyone help me with with an alternative way to solve the
> compatability problem?

Remove PostgreSQL-libs-8.0.2 rpm first... Or upgrade it to 8.0.3...
--
Devrim GUNDUZ
devrim~gunduz.org, devrim~PostgreSQL.org, devrim.gunduz~linux.org.tr
http://www.tdmsoft.com.tr                      http://www.gunduz.org


In response to

Responses

pgsql-admin by date

Next:From: 王晓华Date: 2005-07-29 06:06:57
Subject: start postgresql8 with -o "-i" option
Previous:From: Chris HooverDate: 2005-07-28 17:34:54
Subject: Re: Fwd: Help with view performance problem

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group