Skip site navigation (1) Skip section navigation (2)

Upgrade Questions

From: "Joseph" <lters(at)mrtc(dot)com>
To: <pgsql-novice(at)postgresql(dot)org>
Subject: Upgrade Questions
Date: 2000-05-31 10:19:53
Message-ID: 004201bfcae9$fd91ba40$050101c3@rodstaff.edu (view raw or flat)
Thread:
Lists: pgsql-novice
I have a new Linux 6.2 install.
PostgreSQL 6.5.3 and PHP are installed and running fine.

How do I upgrade with the RPM's?

I am trying to use the 7.0.3's.
When I try to upgrade it says:
        postgresql = 6.5.3 is needed by postgresql-devel-6.5.3-6
        postgresql = 6.5.3 is needed by postgresql-server-6.5.3-6
        libpq.so.2.0 is needed by postgresql-server-6.5.3-6
        libpq.so.2.0 is needed by php-pgsql-3.0.15-2      

If I uninstall the 6.5.3, then I can install the 7.0's.
But then my PHP says it can't find "libpq.so.2.0".

So do I need to uninstall the 6.5.3 or can I upgrade somehow.
Can I use the PHP rpm that I have or does that need upgraded to?

I have no data yet to worry about.

Joseph 


pgsql-novice by date

Next:From: davidbDate: 2000-05-31 15:18:32
Subject: Re: change column after creation?
Previous:From: VShotDate: 2000-05-31 09:46:02
Subject: any tutor/samples for installing/starting/programming on NT ?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group