Skip site navigation (1) Skip section navigation (2)

Re: tcl-devel build dependencies for 7.4.2

From: "Donald Fraser" <demolish(at)cwgsy(dot)net>
To: "[ADMIN]" <pgsql-admin(at)postgresql(dot)org>
Subject: Re: tcl-devel build dependencies for 7.4.2
Date: 2004-04-13 22:58:28
Message-ID: 003b01c421aa$d61a6ef0$1664a8c0@DEMOLITION (view raw or flat)
Thread:
Lists: pgsql-admin
----- Original Message -----
> > I am trying to build Postgres 7.4.2 from the source rpm on Red Hat Linux
7.1
> > 2.96-98
>>
> > error: failed build dependencies:
> >         tcl-devel is needed by postgresql-7.4.2-1PGDG
>
> This dependency is bogus; it doesn't apply to RHL 7.1.  The easiest
> solution is to just add --nodeps and build anyway.  I believe if you
> use the appropriate -D to tell the RPM specfile you're on RHL 7, it
> will suppress the build dependency; but you'd have to look at the
> specfile to figure out what symbol to define, 'cause I don't recall
> offhand ...
>

Thanks - that got things going for me.
Unfortunately it fails to complete the configure script due to the following
messages
...
checking for python... /usr/bin/python
checking Python installation directories... Traceback (innermost last):
  File "<string>", line 1, in ?
ImportError: No module named distutils
Traceback (innermost last):
  File "<string>", line 1, in ?
ImportError: No module named distutils
/usr/
checking how to link an embedded Python application... no
configure: error: Python Makefile not found
error: Bad exit status from /var/tmp/rpm-tmp.24266 (%build)

I'm not sure what those messages mean except that may be I need to upgrade my
python version.
I have previously built the Postgresql rpms from the source for version 7.3.4
without any problems on the this same machine.
Is there a minimum requirements list for building rpms from source anywhere - I
can't think of any other reason why it wouldn't complete?

Thanks again
Donald Fraser


In response to

Responses

pgsql-admin by date

Next:From: Tom LaneDate: 2004-04-14 02:52:12
Subject: Re: tcl-devel build dependencies for 7.4.2
Previous:From: Tom LaneDate: 2004-04-13 21:26:45
Subject: Re: tcl-devel build dependencies for 7.4.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group