Skip site navigation (1) Skip section navigation (2)

Re: Problems with permissions after CYGWIN upgrade

From: "David Garrett" <davidg(at)communication(dot)concepts(dot)cc>
To: "David Garrett" <davidg(at)communication(dot)concepts(dot)cc>,<jason(at)tishler(dot)net>, <pgsql-cygwin(at)postgresql(dot)org>
Subject: Re: Problems with permissions after CYGWIN upgrade
Date: 2003-06-15 08:32:32
Message-ID: 001701c33318$aa896ab0$831e150a@Davidg (view raw or flat)
Thread:
Lists: pgsql-cygwin
Furthermore,  psql did work under administrator when I did a chmod 777 ...

$ ls -l .s*
-rwx------    1 postgres None           51 Jun 15 18:21 .s.PGSQL.5432
-rw-------    1 postgres None           31 Jun 15 18:21 .s.PGSQL.5432.lock

Administrator(at)xxx /tmp
$ chmod 777 .s*

Administrator(at)xxx /tmp
$ ls -l .s*
srwxrwxrwt    1 postgres None            0 Jun 15 18:21 .s.PGSQL.5432
-rwxrwxrwx    1 postgres None           31 Jun 15 18:21 .s.PGSQL.5432.lock
  ----- Original Message ----- 
  From: David Garrett 
  To: jason(at)tishler(dot)net ; pgsql-cygwin(at)postgresql(dot)org 
  Sent: Sunday, June 15, 2003 6:25 PM
  Subject: Problems with permissions after CYGWIN upgrade



  I refer to a recent post ...

  Problems with permissions after CYGWIN upgrade
  http://archives.postgresql.org/pgsql-cygwin/2003-03/msg00053.php
  I have the same problem even though I am using the "postmaster -i" workaround you proposed.

  This is a new installation:
  Cygwin 1.3.22-1
  cygipc 1.14
  postgres 7.3.3

  I believe I followed the install instructions in the README ... in particular

  # cygrunsrv --install postmaster --path /usr/bin/postmaster --args "-D /usr/share/postgresql/data -i" --dep ipc-daemon --termsig INT --user postgres --shutdown

  ... this appears to specify the "-i" option.

  The error I receive is as follows:

  Administrator(at)xxx ~
  $ psql -U postgres template1
  psql: could not connect to server: Bad file descriptor
          Is the server running locally and accepting
          connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

  both the IPC-daemon and postmaster services are running

  FYI
  $ ls -l /tmp/.s*
  -rwx------    1 postgres None           51 Jun 15 18:21 /tmp/.s.PGSQL.5432
  -rw-------    1 postgres None           31 Jun 15 18:21 /tmp/.s.PGSQL.5432.lock

  BUT when logged in as user postgres ... psql works

  All suggestions greatly appreciated


pgsql-cygwin by date

Next:From: Jason TishlerDate: 2003-06-15 12:05:50
Subject: Re: Problems with permissions after CYGWIN upgrade
Previous:From: David GarrettDate: 2003-06-15 08:25:15
Subject: Problems with permissions after CYGWIN upgrade

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group