Skip site navigation (1) Skip section navigation (2)

Installation Problem

From: "BinYang" <byang(at)array(dot)ca>
To: <pgsql-interfaces(at)postgresql(dot)org>
Subject: Installation Problem
Date: 2001-10-15 18:01:04
Message-ID: 001401c155a3$5c069510$7af8c5c0@array.ca (view raw or flat)
Thread:
Lists: pgsql-interfaces
Hi Postgresql,

I encountered a problem when install perl DBI for PostgresSQL. System information: 

Output of perl -v: 

This is perl, v5.6.1 built for sun4-solaris Copyright 1987-2001, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on this system using `man perl' or `perldoc perl'. If you have access to the Internet, point your browser at http://www.perl.com/, the Perl Home Page.

Output of perl -V:

Summary of my perl5 (revision 5.0 version 6 subversion 1) configuration:

Platform:

osname=solaris, osvers=2.8, archname=sun4-solaris

uname='sunos solaris 5.8 generic sun4u sparc sunw,ultra-5_10 '

config_args='-Dcc=gcc -de'

hint=recommended, useposix=true, d_sigaction=define

usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef

useperlio=undef d_sfio=undef uselargefiles=define usesocks=undef

use64bitint=undef use64bitall=undef uselongdouble=undef

Compiler:

cc='gcc', ccflags ='-fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',

optimize='-O',

cppflags='-fno-strict-aliasing -I/usr/local/include'

ccversion='', gccversion='2.95.3 20010315 (release)', gccosandvers='solaris2.8'

intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321

d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16

ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8

alignbytes=8, usemymalloc=y, prototype=define

Linker and Libraries:

ld='gcc', ldflags =' -L/usr/local/lib '

libpth=/usr/local/lib /usr/lib /usr/ccs/lib

libs=-lsocket -lnsl -lgdbm -ldb -ldl -lm -lc

perllibs=-lsocket -lnsl -ldl -lm -lc

libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a

Dynamic Linking:

dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '

cccdlflags='-fPIC', lddlflags='-G -L/usr/local/lib'



Characteristics of this binary (from libperl): 

Compile-time options: USE_LARGE_FILES

Built under solaris

Compiled at Apr 26 2001 04:07:49

@INC:

/usr/local/lib/perl5/5.6.1/sun4-solaris

/usr/local/lib/perl5/5.6.1

/usr/local/lib/perl5/site_perl/5.6.1/sun4-solaris

/usr/local/lib/perl5/site_perl/5.6.1

/usr/local/lib/perl5/site_perl

.

The Version of PostgreSQL: 7.1.3

The Version of pgsql_perl5: 1.9.0


Problem: 

I have POSTGRES_INCLUDE and POSTGRES_LIB set up. When run "perl Makefile.PL" as PostgreSQL user I got following message.


# perl Makefile.PL

Configuring Pg

Remember to actually read the README file !

OS:solaris

Writong Makefile for Pg

Unable to open MakeMaker.tmp: Permission denied at /usr/local/lib/perl5/5.6.1/ExtUtils/MakeMaker.pm line 750.


When run this as root there is no problem. Could you please help me to resolve this problem, I'm looking forward to receive your reply. 


Thanks a lot!


Bin Yang

System Administrator

Array Systems Computing Inc.

pgsql-interfaces by date

Next:From: Dan WilsonDate: 2001-10-15 22:53:05
Subject: phpPgAdmin finds new home
Previous:From: Constantin TeodorescuDate: 2001-10-15 15:57:20
Subject: Re: Kylix

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group