Skip site navigation (1) Skip section navigation (2)

Problem at install / uninstall postgresql

From: Miguel Pedreño Saura <mipesa(at)coitt(dot)es>
To: <pgsql-bugs(at)postgresql(dot)org>
Subject: Problem at install / uninstall postgresql
Date: 2006-08-23 17:05:27
Message-ID: 000f01c6c6d6$5831d680$c601a8c0@MIPESA (view raw or flat)
Thread:
Lists: pgsql-bugs
            I’m installing postgresql in a O.S. Linux Ubuntu 6.06 and I
have the next printout at installation process:
 
 
Setting up postgresql-7.4 (7.4.12-3) ...
Error: cluster configuration already exists
 
 
            I can’t find information about how I can solve the problem
at Internet and I can install/uninstall anythings.
 
 
root(at)estigio:/tmp# aptitude install postgresql
Reading package lists... Done
Building dependency tree... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Setting up postgresql-7.4 (7.4.12-3) ...
Error: cluster configuration already exists
dpkg: error processing postgresql-7.4 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql:
 postgresql depends on postgresql-7.4; however:
  Package postgresql-7.4 is not configured yet.
dpkg: error processing postgresql (--configure):
… 
 
postgresql-pltcl-7.4 depends on postgresql-7.4; however:
  Package postgresql-7.4 is not configured yet.
dpkg: error processing postgresql-pltcl-7.4 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 postgresql-7.4
 postgresql
 postgresql-plperl-7.4
 postgresql-plpython-7.4
 postgresql-pltcl-7.4
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up postgresql-7.4 (7.4.12-3) ...
Error: cluster configuration already exists
dpkg: error processing postgresql-7.4 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql-pltcl-7.4:
 postgresql-pltcl-7.4 depends on postgresql-7.4; however:
 
…..
  Package postgresql-7.4 is not configured yet.
dpkg: error processing postgresql-plpython-7.4 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 postgresql-7.4
 postgresql-pltcl-7.4
 postgresql
 postgresql-plperl-7.4
 postgresql-plpython-7.4
root(at)estigio:/tmp#
 
 
 
Thanks, Miguel
 

pgsql-bugs by date

Next:From: Caitie HumphreyDate: 2006-08-23 18:57:59
Subject: BUG #2589: corrupt file
Previous:From: Evgeny GridasovDate: 2006-08-23 15:13:12
Subject: BUG #2588: rename table and dump bug

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group