Skip site navigation (1) Skip section navigation (2)

Re: Initdb not running on beos

From: Cyril VELTER <cyril(dot)velter(at)libertysurf(dot)fr>
To: pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: Initdb not running on beos
Date: 2000-11-27 20:36:40
Message-ID: 00037715175c35ca_mailit@mail.cybercable.fr (view raw or flat)
Thread:
Lists: pgsql-hackers

    Unfortunatly, there is no hard link on beos :=(. link and unlink are 
there, but link always return "No such file or directory".

    BTW, What the code in XLogFileInit is supposed to do ? Why not create the 
file with the right name in the first step ?

    I have tried to create the file whith the right name and remove all link/
unlink. After that, initdb does works but after I have a quite strange 
behavior :    
    * Every select return 0 row (the columns are there, but no datas)
    * Every create  or insert crash the backend.
    * If I do nothing, the backend will crash after some minutes
    
    is it related to the first hack ? or is there something else ?


            cyril


>Cyril VELTER <cyril(dot)velter(at)libertysurf(dot)fr> writes:
>> FATAL 2:  InitReopen(logfile 0 seg 0) failed: No such file or directory
>
>Does BeOS not support link(2) ?
>
>See XLogFileInit() in src/backend/access/transam/xlog.c.
>
>			regards, tom lane
>


Responses

pgsql-hackers by date

Next:From: DaveDate: 2000-11-27 20:47:00
Subject: JDBC charSet patch
Previous:From: Bruce MomjianDate: 2000-11-27 20:09:46
Subject: Re: location of Unix socket

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group