Skip site navigation (1) Skip section navigation (2)

Performance problems

From: "Stuart" <stuart(at)theallisons(dot)freeserve(dot)co(dot)uk>
To: <pgsql-odbc(at)postgresql(dot)org>
Subject: Performance problems
Date: 2001-10-31 23:07:11
Message-ID: 000201c16260$fc2a5620$7d7a7d7a@saahome (view raw or flat)
Thread:
Lists: pgsql-odbc
Hi

I have downloaded psqlodbc-07_01_0007.zip to my Windows 98 PC and I am using this successfully with Paradox v7.
The Paradox script I have runs on some local Paradox 7 tables, and populates around 50K records in 2 tables in under 1 minute.

I have the same tables in Postgres on a networked Linux PC: this has SuSe 6.2 with kernel 2.4.10, and Postgres 7.1.3. 
I copied the table structure from Paradox to my Postgres database and ran the same Paradox script, now using the ODBC to connect to the 2 tables in Postgres. Over 8 hours later, I only had 15K records: any idea what's going on?

There is no logging set in the ODBC connection, nor is the debug on.

Incidentally, when I activated Zonealarm, it shows the network activity, and showed that in those 8 hours, 20Mb of data was sent, but over 3Gb was received! What's this for?? I deactivated Zonealarm, but the performance was the same.

Regards

Stuart



pgsql-odbc by date

Next:From: Andrea AimeDate: 2001-11-06 10:20:56
Subject: Weird problem with aggregate functions
Previous:From: Raul BreindembachDate: 2001-10-31 17:53:23
Subject: Me retiro de la lista

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group