This page in other versions: Unsupported versions: 6.4 / 6.5 / 7.0

Chapter 25. Installation

Installation instructions for PostgreSQL 7.0.

If you haven't gotten the PostgreSQL distribution, get it from ftp.postgresql.org, then unpack it:

> gunzip postgresql-7.0.tar.gz
> tar -xf postgresql-7.0.tar
> mv postgresql-7.0 /usr/src
   

Before you start

Building PostgreSQL requires GNU make. It will not work with other make programs. On GNU/Linux systems GNU make is the default tool, on other systems you may find that GNU make is installed under the name gmake. We will use that name from now on to indicate GNU make, no matter what name it has on your system. To test for GNU make enter

> gmake --version
    
If you need to get GNU make, you can find it at ftp://ftp.gnu.org.

Up to date information on supported platforms is at http://www.postgresql.org/docs/admin/ports.htm. In general, most Unix-compatible platforms with modern libraries should be able to run PostgreSQL. In the doc subdirectory of the distribution are several platform-specific FAQ and README documents you might wish to consult if you are having trouble.

Although the minimum required memory for running PostgreSQL can be as little as 8MB, there are noticeable speed improvements when expanding memory up to 96MB or beyond. The rule is you can never have too much memory.

Check that you have sufficient disk space. You will need about 30 Mbytes for the source tree during compilation and about 5 Mbytes for the installation directory. An empty database takes about 1 Mbyte, otherwise they take about five times the amount of space that a flat text file with the same data would take. If you run the regression tests you will temporarily need an extra 20MB.

To check for disk space, use

> df -k

Considering today's prices for hard disks, getting a large and fast hard disk should probably be in your plans before putting a database into production use.

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group