From 49b51b362b4d86103c74057186154a42b9ef335b Mon Sep 17 00:00:00 2001 From: Peter Eisentraut Date: Mon, 17 Feb 2020 17:35:48 +0100 Subject: [PATCH 1/3] pg_resetwal: Rename function to avoid potential conflict ReadControlFile() here conflicts with a function of the same name in xlog.c. There is no actual conflict right now, but since pg_resetwal.c reaches deep inside backend headers, it's possible in the future. --- src/bin/pg_resetwal/pg_resetwal.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/src/bin/pg_resetwal/pg_resetwal.c b/src/bin/pg_resetwal/pg_resetwal.c index f9cfeae264..c9edeb54d3 100644 --- a/src/bin/pg_resetwal/pg_resetwal.c +++ b/src/bin/pg_resetwal/pg_resetwal.c @@ -76,7 +76,7 @@ static int WalSegSz; static int set_wal_segsize; static void CheckDataVersion(void); -static bool ReadControlFile(void); +static bool read_controlfile(void); static void GuessControlValues(void); static void PrintControlValues(bool guessed); static void PrintNewControlValues(void); @@ -393,7 +393,7 @@ main(int argc, char *argv[]) /* * Attempt to read the existing pg_control file */ - if (!ReadControlFile()) + if (!read_controlfile()) GuessControlValues(); /* @@ -578,7 +578,7 @@ CheckDataVersion(void) * to the current format. (Currently we don't do anything of the sort.) */ static bool -ReadControlFile(void) +read_controlfile(void) { int fd; int len; -- 2.25.0