On Sat, Feb 2, 2019 at 12:48 AM Daniel Gustafsson <daniel(at)yesql(dot)se> wrote: > + new_uris = psprintf("%s%s%s://%s:%d", > > While this construction isn't introduced in this patch, would it not make sense > to convert uris to StringInfo instead to improve readability?
Yeah. This coding is ugly and StringInfo would be much nicer. Thinking about that made me realise that the proposed SRV case should also handle multiple SRV records by building a multi-URL string too (instead of just taking the first one). I will make it so.