|From:||Andrew Dunstan <andrew(at)dunslane(dot)net>|
|To:||Pavel Stehule <pavel(dot)stehule(at)gmail(dot)com>|
|Subject:||Re: jsonb generator functions|
|Views:||Raw Message | Whole Thread | Download mbox | Resend email|
On 10/15/2014 03:54 PM, Andrew Dunstan wrote:
>> I checked a code, and I have only two small objection - a name
>> "jsonb_object_two_arg" is not good - maybe "json_object_keys_values" ?
> It's consistent with the existing json_object_two_arg. In all cases I
> think I kept the names the same except for changing "json" to "jsonb".
> Note that these _two_arg functions are not visible at the SQL level -
> they are only visible in the C code.
> I'm happy to be guided by others in changing or keeping these names.
>> Next: there are no tests for to_jsonb function.
> Oh, my bad. I'll add some.
> Thank for the review.
Here is a new patch that includes documentation and addresses all these
issues, except that I didn't change the name of jsonb_object_two_arg to
keep it consistent with the name of json_object_two_arg. I'm happy to
change both if people feel it matters.
|Next Message||Stephen Frost||2014-10-27 14:47:29||Re: Review of GetUserId() Usage|
|Previous Message||Andres Freund||2014-10-27 13:51:41||Re: proposal: CREATE DATABASE vs. (partial) CHECKPOINT|