Skip site navigation (1) Skip section navigation (2)

Re: per-tablespace random_page_cost/seq_page_cost

From: Josh Berkus <josh(at)agliodbs(dot)com>
To: Robert Haas <robertmhaas(at)gmail(dot)com>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: per-tablespace random_page_cost/seq_page_cost
Date: 2009-10-26 22:05:20
Message-ID: (view raw, whole thread or download thread mbox)
Lists: pgsql-hackers

> As to (1), my thought is to add two new float8 columns to
> pg_tablespace.  The naming is a little awkward, because
> random_page_cost and seq_page_cost would not fit with our (rather odd)
> convention for naming system catalog columns.  I'm tempted to call
> them spcrandompagecost and spcseqpagecost, but I wonder if anyone has
> any strong preferences.

I'm thinking an array, in case we want to make other tablespace cost
parameters in the future.*  Or, better, whatever structure we're
currently using for ROLEs.

(* for example, if someone does manage a filesystem with a separate
cache space per mount, then we'd want effective_cache_size to be
tablespace-based as well)


In response to


pgsql-hackers by date

Next:From: Alvaro HerreraDate: 2009-10-26 22:11:09
Subject: Re: "toast.fillfactor" is documented but not recognized?
Previous:From: Andrew DunstanDate: 2009-10-26 22:03:12
Subject: Re: Anonymous Code Blocks as Lambdas?

Privacy Policy | About PostgreSQL
Copyright © 1996-2017 The PostgreSQL Global Development Group