Marko Tiikkaja <marko(dot)tiikkaja(at)cs(dot)helsinki(dot)fi> writes:
> On 2011-02-24 6:20 PM +0200, Tom Lane wrote:
>> The best idea I have at the moment is to spell out "data modifying
>> command" (or "statement") rather than relying on the acronym.
>> In the code, we could change hasDmlWith to hasModifyingWith, for
>> example. The error messages could read like
>> data-modifying statement in WITH is not allowed in a view
> Out of everything suggested so far, I think this is the best we have, if
> we can fit the whole thing into out error messages. Quickly grepping
> through the patch suggests that we can, at least for the cases in the
> current patch.
> I also prefer "statement" over "command".
OK, I will make those adjustments. Are you going to do more work on the
documentation part of the patch? I can stick to working on the code
part meanwhile, if you are.
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Marko Tiikkaja||Date: 2011-02-24 16:40:58|
|Subject: Re: wCTE: about the name of the feature|
|Previous:||From: Florian Pflug||Date: 2011-02-24 16:36:39|
|Subject: Re: Possible substitute for PostmasterIsAlive polling loops|