Skip site navigation (1) Skip section navigation (2)

Getting "ident" to work in Windows

From: Thomas Kellerer <spam_eater(at)gmx(dot)net>
To: pgsql-admin(at)postgresql(dot)org
Subject: Getting "ident" to work in Windows
Date: 2012-05-04 11:57:47
Message-ID: jo0g4q$pq8$1@dough.gmane.org (view raw or flat)
Thread:
Lists: pgsql-admin
Hi,

I'm trying to enable "ident" authentication on my Windows machine using PostgreSQL 9.1

However as soon as I add the following line to pg_hba.conf

    host    all             all             ::1/128            ident sameuser

I get an error message when trying to login (after a server reload of course)

    psql: FATAL:  could not load pg_hba.conf

It is precisely that line above. As soon as I remove it I can logon again (with a username/password of course).

I did verify that my connections are done through IPV6.

Here is the current content of my pg_hba.conf:

--------- snip ----------
# TYPE  DATABASE        USER            ADDRESS                 METHOD

# IPv4 local connections:
host    all             all             127.0.0.1/32            md5

# IPv6 local connections:
host    all             all             ::1/128              md5
--------- snip ----------

Ideally I would like to make "ident" to work with a custom map but using "ident tkmap". But that throws the same error which isn't really surprising as "ident tkmap" is not working either.

Is ident not supported on Windows? I could not find anything related to that in the manual.

Regards
Thomas




Responses

pgsql-admin by date

Next:From: Magnus HaganderDate: 2012-05-04 13:22:12
Subject: Re: Getting "ident" to work in Windows
Previous:From: GnanakumarDate: 2012-05-04 11:32:27
Subject: Re: Very long "<IDLE> in transaction" query

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group