Skip site navigation (1) Skip section navigation (2)

Re: Shared object "libpq.so.3" not found

From: marko <marko(dot)online(at)gmail(dot)com>
To: pgsql-general(at)postgresql(dot)org
Subject: Re: Shared object "libpq.so.3" not found
Date: 2008-07-31 10:11:24
Message-ID: dd03db67-54f7-4fc8-b022-8f1199a2984f@27g2000hsf.googlegroups.com (view raw or flat)
Thread:
Lists: pgsql-general
On Jul 31, 1:34 am, t(dot)(dot)(dot)(at)sss(dot)pgh(dot)pa(dot)us (Tom Lane) wrote:
> marko <marko(dot)onl(dot)(dot)(dot)(at)gmail(dot)com> writes:
> > I'm running FreeBSD 6.2 and I have Postgresql 8.2.4 installed with
> > Perl v5.8.8.  I'm trying to test DBD-Pg-2.8.7 after compilation and I
> > get this error after 'make test':
> > #     Error:  Can't load '/usr/home/markuser/DBD-Pg-2.8.7/blib/arch/
> > auto/DBD/Pg/Pg.so' for module DBD::Pg: Shared object "libpq.so.3" not
> > found, required by "Pg.so" at /usr/local/lib/perl5/5.8.8/mach/
> > DynaLoader.pm line 230.
>
> libpq.so.3 corresponds to the libpq version that was shipped in
> PG release series 7.3.x and 7.4.x.  8.2 provides libpq.so.5.
>
> Your subsequent comments make it pretty clear that you've got
> (at least portions of) both 7.x and 8.x PG installations on your
> machine.  I'd suggest flushing all traces of the older one and
> then rebuilding DBD::Pg from a clean start.  Somehow it's been
> seizing on the older PG installation as the one to link to...
>
>                         regards, tom lane
>

OK...  I can't say that I remember installing a 7.x PG version.  I
wanted to make sure there wasn't some FreeBSD bug out there relative
to these packages.  Thanks.

In response to

pgsql-general by date

Next:From: Bohdan LindaDate: 2008-07-31 10:43:21
Subject: Re: Weird pg_ctl behaviour via ssh
Previous:From: Cousin FlorenceDate: 2008-07-31 09:52:19
Subject: Rappel :

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group