Skip site navigation (1) Skip section navigation (2)

Re: Preocupacion con PostgreSQL

From: "Felipe Amezquita" <felmarla(at)gmail(dot)com>
To: postgresayuda <pgsql-es-ayuda(at)postgresql(dot)org>
Subject: Re: Preocupacion con PostgreSQL
Date: 2007-11-26 19:40:51
Message-ID: bf4cfe570711261140v3d353298r3b5a16417312eda9@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Bueno amigos de la lista...Espero se encuentren de maravilla
Que tal lista.
Otro error que se me esta presentando en el log es el siguiente

select oid, typbasetype from pg_type where typename = 'lo'
could not open relation..

Por que puede ocurrir esto,tiene algo que ver el odbc con que me estoy
conectado.

Necesito sugerencias.
Gracias

El día 17/11/07, Felipe Amezquita <felmarla(at)gmail(dot)com> escribió:
>
>
> Que tal mis querido amigo de la lista..Espero se encuentren bien.


Si ejecuto las consultas desde el PgADMIN no presenta ningun error ninguna
de las consultas.
En casi todos los casos que hago un select del OID en la tabla pg_class yo
las encuentro, que es lo mas curioso de todo, pero hay otra cosa rara y es
que despues de que se reindexaron el pg_class y pg_tablespace empezaron a
mostrace  mas seguido los errores del invalid argument y con unos codigos
OID muy grandes, los cuales le hago la consulta en la tabla pg_class y no
muestra nada.

En realidad estoy muy desesperado por que no se que mas hacer.

Y lo del enviar una copia de la bd me gustaria saber sy la envio la
estructura en un backup y los datos en otro o juntos.

Yo tengo un sistema que se conecta via ODBC y esta creado en .NET C#

Y el problema si se me presenta en las dos versiones 8.0,8.1 y 8.2.
No se que tanto tenga que ver la version del sistemas operativo,recuerden
que es 2003 server.

De nuevo gracias y espero su colaboracion.

En esta oportunidad que les ecribo por que hay una situación que me tiene
> realmente preocupado con respecto al motor de BD,ya que dede hace unos dias
> venia presentado problemas de bloqueo aproximadamnete cada 45 minutos.
>
> Yo ya habia escrito al respecto y las conclusiones fueron pocas,el unico
> fue el ilustricimo Alvaro Herrera quien dio una pequeña opinion.
>
> El cuento es el siguiente haciendo, seguimiento al log el muestra unos
> errores de este tipo y son muy frecuentes
>
> 2007-11-16 14:54:16 ERROR:  could not open relation 1663/16403/16487:
> Invalid argument
>
> 2007-11-16 14:54:16 CONTEXT:  SQL statement "select ccomo_codigo from
> clase_comodin where (ccomo_nombre)= initcap(lower( $1 ))"
>
>     PL/pgSQL function "get_codigo_clase_comodin" line 4 at SQL statement
>
> 2007-11-16 15:06:38 ERROR:  could not open relation 1663/16403/24620:
> Invalid argument
>
> 2007-11-16 15:06:38 STATEMENT:  select oid, typbasetype from pg_type where
> typname = 'lo'
>
> 2007-11-16 15:07:22 ERROR:  could not open relation 1663/16403/16601:
> Invalid argument
>
> 2007-11-16 15:07:22 CONTEXT:  SQL statement "select ent_codigo from
> entidad where lower(ent_nombre) like lower( $1 )"
>
>     PL/pgSQL function "get_codigo_entidad" line 4 at SQL statement
>
> 2007-11-16 15:07:22 STATEMENT:  fetch all in "ref"
>
> 2007-11-16 15:08:45 ERROR:  could not open relation 1663/16403/24755:
> Invalid argument
>
> 2007-11-16 15:08:45 CONTEXT:  SQL statement "select count(*) from cuota
> where (cuota.est_codigo = 'Ac' or cuota.est_codigo = 'Mo' or
> cuota.est_codigo = 'Pu') and cuota.prg_codigo =  $1  and cuota.cap_codigo<  $2  and
> cuota.cuo_fraccion = 0"
>
>     PL/pgSQL function "es_posible_pago_cuotas" line 24 at SQL statement
>
> Alvaro me decia que seguramente yo habia hecho alguna jugarreta con el
> tablespace y que estaba corrupto, entonces que el Backup con que yo contaba
> para restablecer el servidor habia quedado con esos errores. Depues de tanto
> leer e indagar nunca encontre una solucion, entonces decidi copiar los datos
> de la actual BD y desde cero crear un nuevo DataBase con nombre diferenete y
> por supuesto crear toda la estructura desde cero compilada uno a uno haber
> si asi solucinaba este problema.
>
> Pero al parecer esta solucion no funciono ya que se sigue presentado este
> error, entonces lo que quiere decir que ese error no es causado por lo que
> opino Alvaro.
>
> Quiero saber si en realidad alguien tiene una solucion para este problema
> ya que estoy al borde de desertar. Por favor ayudenme.
>
> Version PostgreSQL 8.2 aunque tengo instalada en otras sede 8.0 y 8.1 y es
> igual.
>
> Gracias de nuevo.
> --
> Ing Sistemas y Telecomunicaciones
> Luis Felipe Lopez Amezquita
> 3008217523 - 3146286237 - 3173160602




-- 
Ing Sistemas y Telecomunicaciones
Luis Felipe Lopez Amezquita
3008217523 - 3146286237 - 3173160602

In response to

Responses

pgsql-es-ayuda by date

Next:From: Alvaro HerreraDate: 2007-11-26 20:09:28
Subject: Re: Preocupacion con PostgreSQL
Previous:From: rosorioDate: 2007-11-26 17:40:07
Subject: Re: Conve=?ISO-8859-1?Q?rsi=F3n_de_LATI?=N1 a UTF8

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group