Skip site navigation (1) Skip section navigation (2)

Upgrading from 6.3->6.4.2/6.5b1 possible

From: Gregory Maxwell <greg(at)z(dot)ml(dot)org>
To: pgsql-general(at)hub(dot)org
Subject: Upgrading from 6.3->6.4.2/6.5b1 possible
Date: 1999-05-30 21:14:00
Message-ID: Pine.LNX.3.96.990530170703.1178A-100000@z.ml.org (view raw or flat)
Thread:
Lists: pgsql-general
AHH! The pgsql v6.3 backend has begun crashing horribly on me since I've
added a few more database backed webpages (with messages like 'backend
cache invalidation...').. I figured that upgrading to 6.4.2 would solve my
problems.. But I can't upgrade! Things I've tried:

* Using old pg_dumpall -z > file and psql -e template1 < file (after
  install and initdb)
* Using the pg_dumpall from the new version.
* Using pg_upgrade 
* Rereading the docs dozens of times
* having a friend try it.
* all of the above with both 6.4.2 and 6.5beta

Every time I start loading, it chokes up on the dump output and falls into
a constant stream of parse errors and messages like "PQsendQuery() --
query is too long.  Maximum length is 8191"

Argh!!! I've got websites constantly crashing and coustomers ready to
revolt, what can I do???







Responses

pgsql-general by date

Next:From: Oliver ElphickDate: 1999-05-30 22:35:30
Subject: Re: [GENERAL] Upgrading from 6.3->6.4.2/6.5b1 possible
Previous:From: Herouth MaozDate: 1999-05-30 10:53:37
Subject: Re: [GENERAL] ownership of tables. . .

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group