Skip site navigation (1) Skip section navigation (2)

Re: ODBC problem

From: "Hiroshi Inoue" <Inoue(at)tpf(dot)co(dot)jp>
To: "Graeme Leeming" <gleeming(at)refractions(dot)net>
Cc: <bugs(at)safe(dot)com>, <pgsql-odbc(at)postgresql(dot)org>
Subject: Re: ODBC problem
Date: 2002-01-18 22:37:52
Message-ID: EKEJJICOHDIEMGPNIFIJOEFJGIAA.Inoue@tpf.co.jp (view raw or flat)
Thread:
Lists: pgsql-odbc
> -----Original Message-----
> From: Graeme Leeming
> 
> I have upgraded to build 537 of FME on WinNT and am trying to connect to
> a Postgresql database through ODBC (this has worked properly with build
> 519 and PSQLodbc v7.01.00.05/6).  The error message I get back from the
> translator is:
> 
> "[NOTSUPPORTED] The specified ODBC Data Source uses an ODBC driver which
> conforms to an ODBC specification prior to the 3.0 specification.  This
> driver version is not supported by DBTools.h++.  Please upgrade to a
> newer driver.' (VendorMessage1=`', VendorMessage2=`')"
> 
> I tried using the latest version of PSQLODBC I could find, 7.01.00.09,
> but still the same error occurs.  Since I don't know what the 3.0
> specification entails, is there a way around this apparent limitation
> now imposed by the new build of FME, and/or is a 3.0 compliant ODBC
> driver available or planned for Postgres?

There are some code for ODBC 3.0 but I couldn't guarantee when 
it would be ready. At least I could send you the halfway driver if 
you'd like to see how far it is from your requirement.

regards,
Hiroshi Inoue

In response to

pgsql-odbc by date

Next:From: Hiroshi InoueDate: 2002-01-21 02:36:40
Subject: Re: [ODBC] odbc error
Previous:From: Hiroshi InoueDate: 2002-01-18 22:37:46
Subject: Re: Problems with Visual Basic

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group